summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-10-16 20:19:45 -0500
committerBen Kohler <bkohler@gentoo.org>2024-10-16 20:19:59 -0500
commitc1d693cc4fc62d4129d2cd35a99730ba4c40688e (patch)
tree61bda5f509d47878c87ef7a78e8ac7332503f295 /net-misc/dropbox
parentapp-admin/syslog-ng: drop 4.8.0 (diff)
downloadgentoo-c1d693cc4fc62d4129d2cd35a99730ba4c40688e.tar.gz
gentoo-c1d693cc4fc62d4129d2cd35a99730ba4c40688e.tar.bz2
gentoo-c1d693cc4fc62d4129d2cd35a99730ba4c40688e.zip
net-misc/dropbox: add 210.4.4854
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/dropbox')
-rw-r--r--net-misc/dropbox/Manifest1
-rw-r--r--net-misc/dropbox/dropbox-210.4.4854.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/dropbox/Manifest b/net-misc/dropbox/Manifest
index 208925269d01..69e5b47f31f4 100644
--- a/net-misc/dropbox/Manifest
+++ b/net-misc/dropbox/Manifest
@@ -2,3 +2,4 @@ DIST dropbox-icon.svg 574 BLAKE2B a73a0906b5b03dc3214010736164fcdbceb6d91463ed95
DIST dropbox-lnx.x86-205.4.5765.tar.gz 114089572 BLAKE2B 503650c9fe49c1142872b829892c3759924af57c0327d49b3891f78cbad9b8aa4964861b719023ce5dc837fac98937559635a3e9c16da5b352b104c3cba792c3 SHA512 35715777719c10f38b54e92e24af5d6af85e4caedb7b45bef0693f93d7b0faa0da81b772f821ff4c4a60065e68ac98769cdf0655cce557550d1040f1c765598e
DIST dropbox-lnx.x86_64-205.4.5765.tar.gz 116601880 BLAKE2B 40fbef3634736e4350d7b5e3bcf70d9daf1524d06b7707a7abeeff53020e2e51e3816a42903fc172ea9b8c721b769450d56cdb3f2fd562e114ce377b8cca4465 SHA512 9b9246ad573f0b04a9a403e6c71e2924da453f448a69bf8e24b1d662a80461b19a8fb75d29411006cf6b38b2227f4e5e94c57f481612d89621fc2ce985d8d450
DIST dropbox-lnx.x86_64-209.4.3661.tar.gz 117384855 BLAKE2B 509c1e3b8eab3e44b6b713988b7bebc83f9ee62c94100fceb163496d5b419c4caaf933f9646e21ad996a303140639b7de44b2a52fac942adc23a1973a86149ab SHA512 769c3063f87732ecc82e44e1de7ffa581d313fbdecf2230304730ab58da0e4a0bf284e3188897d066c961a5e25316c481b47d46e6dc015a5b974ade7074a4b54
+DIST dropbox-lnx.x86_64-210.4.4854.tar.gz 117607664 BLAKE2B 402717c16c063de5b506826cdf2862eab009e3b8c28eda64deebc7dc9637947c1d46dec183a99bab3353257e1ca118e4fe72f390537175038a0b25eb7adc8a6a SHA512 4331999d87e7326dd6a60bb1aebce94326e776a595f6222bd9238a4225139b84324bde6215162aece0eb87868e1e6320092ba40d6fff684dbdc39535dc5426b4
diff --git a/net-misc/dropbox/dropbox-210.4.4854.ebuild b/net-misc/dropbox/dropbox-210.4.4854.ebuild
new file mode 100644
index 000000000000..9aafe425d4d6
--- /dev/null
+++ b/net-misc/dropbox/dropbox-210.4.4854.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils systemd xdg
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="
+ https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz
+ https://uxwing.com/wp-content/themes/uxwing/download/brands-and-social-media/dropbox-icon.svg
+"
+
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="selinux X"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/.*"
+QA_EXECSTACK="opt/dropbox/dropbox"
+
+BDEPEND="dev-util/patchelf"
+
+# Be sure to have GLIBCXX_3.4.9, #393125
+RDEPEND="
+ X? (
+ x11-themes/hicolor-icon-theme
+ )
+ selinux? ( sec-policy/selinux-dropbox )
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libffi-compat:6
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/wget
+ sys-libs/zlib
+ sys-libs/ncurses-compat:5
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}" || die
+ mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
+ mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
+ rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
+ rmdir .dropbox-dist || die
+}
+
+src_prepare() {
+ default
+ # we supply all of these in RDEPEND
+ rm -vf libGL.so.1 libX11* libffi.so.6 || die
+ # some of these do not appear to be used
+ rm -vf libQt5{OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets}.so.5 \
+ PyQt5.QtPrintSupport.* PyQt5.QtQml.* PyQt5.QtQuick.* \
+ wmctrl libdrm.so.2 libpopt.so.0 || die
+ if use X ; then
+ mv images/hicolor/16x16/status "${T}" || die
+ else
+ rm -vrf images || die
+ fi
+ patchelf --set-rpath '$ORIGIN' \
+ apex._apex.*.so \
+ nucleus_python.*.so \
+ tprt.*.so \
+ || die
+ pax-mark cm dropbox
+ mv README ACKNOWLEDGEMENTS "${T}" || die
+}
+
+src_install() {
+ local targetdir="/opt/dropbox"
+
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}"/{dropbox,dropboxd}
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+
+ if use X; then
+ doicon -s 16 -c status "${T}"/status
+ newicon -s scalable "${DISTDIR}/dropbox-icon.svg" dropbox.svg
+ fi
+
+ make_desktop_entry "${PN}" "Dropbox" "dropbox"
+
+ newinitd "${FILESDIR}"/dropbox.initd dropbox
+ newconfd "${FILESDIR}"/dropbox.conf dropbox
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
+
+ dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
+}
+
+pkg_postinst() {
+ einfo "Warning: while running, dropbox may attempt to autoupdate itself in"
+ einfo " your user's home directory. To prevent this, run the following as"
+ einfo " each user who will run dropbox:"
+ einfo ""
+ einfo "install -dm0 ~/.dropbox-dist"
+}