summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-25 21:15:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-25 21:26:06 +0100
commitb2568bc02a52a2feda0653c2fe9c4fc0adcc11d1 (patch)
tree1db43891505d92644d6a2c8256ae2a2f670d45b3 /net-misc/gallery-dl
parentnet-misc/gallery-dl: use EAPI 8 in live (diff)
downloadgentoo-b2568bc02a52a2feda0653c2fe9c4fc0adcc11d1.tar.gz
gentoo-b2568bc02a52a2feda0653c2fe9c4fc0adcc11d1.tar.bz2
gentoo-b2568bc02a52a2feda0653c2fe9c4fc0adcc11d1.zip
net-misc/gallery-dl: bump to 1.19.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.19.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 53186ac6a256..88be233ad842 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.17.5.tar.gz 359212 BLAKE2B 12c8ba8e25e8979cb9230283b40f9e11c23032f281cdf73975b1099c76d9007c68246be0e961d29d4686ce12790cf31c4ed0e3c83d91984ce11b0008176157a3 SHA512 c630156c3b16499f33d3850935f5f37d85a443041448f1edf5d0b91a36b8b73a83248a9b2f6da99d5c679b6d1759100eb42f6b50650b914f67c1928e2491bf00
DIST gallery-dl-1.18.1.tar.gz 368692 BLAKE2B f92eb7a876563ed5bc78ca1222b8c45fe78ad6d899a55bf2edefece14209acfc784bc3ac84c7e84397746f5a5ab01c2c6f94efcb0f28d2aacac3cbd68ebcd545 SHA512 20e4f983160870a646a66963505d2c53f5498b9bbbb869a603ae53848ee788f26c6df4c5951805d99f225954ddbe692c2da5501a409650cc3e522d97f34a7c0d
+DIST gallery-dl-1.19.2.tar.gz 393664 BLAKE2B cae6b2cdd9f940892032498c0450918481aea22a701b236f580e6c7d2f77b7ce5fb2336a93c882b35063eb0193b9ebb956f8d12e8b6794255318b6eb65ee9de9 SHA512 7aa014e0e84d856bd9ca45131baed513f1d3c73c1500df32c39b5a40f17cd951e80b819130254f9b563a504866e5feebabf6b5c8bf517a43a6ad7a15e41f0476
diff --git a/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
new file mode 100644
index 000000000000..5ceaa421ee3b
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{8,9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/{,_}gallery-dl man
+
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}