summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-08-09 10:00:54 +0200
committerPatrick Lauer <patrick@gentoo.org>2019-08-09 10:00:54 +0200
commitc1c4a605f6477bdbcb2a77e1bc23907e48e6f09c (patch)
tree58d3dd97d8543645b48775ab3d71251908410c54 /net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild
parentdev-db/mongodb: drop old ebuilds (diff)
downloadgentoo-c1c4a605f6477bdbcb2a77e1bc23907e48e6f09c.tar.gz
gentoo-c1c4a605f6477bdbcb2a77e1bc23907e48e6f09c.tar.bz2
gentoo-c1c4a605f6477bdbcb2a77e1bc23907e48e6f09c.zip
net-misc/geoipupdate: Fixes
Fix #691730 Fix #691732 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild')
-rw-r--r--net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild b/net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild
new file mode 100644
index 000000000000..f8f05abf74d5
--- /dev/null
+++ b/net-misc/geoipupdate/geoipupdate-4.0.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/maxmind/${PN}"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="performs automatic updates of GeoIP2 and GeoIP Legacy binary databases"
+HOMEPAGE="https://${EGO_PN}"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://files.adjust.com/${PN}-vendor-${PV}.tar"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( GeoIP.conf.md geoipupdate.md )
+
+src_unpack() {
+ golang-vcs-snapshot_src_unpack
+ tar xf "${DISTDIR}/${PN}-vendor-${PV}.tar" -C "${S}/src/github.com/maxmind/geoipupdate" || die
+}
+
+src_compile() {
+ cd src/${EGO_PN} || die
+ # requires pandoc but the information is still in the distributed md files
+ sed -i -e '/GeoIP.conf.5 /d' -e '/geoipupdate.1$/d' Makefile || die
+ sed -i -e 's/go build/go build -x/' Makefile || die
+
+ # the horror, the horror ... but it's all automagic
+ export GO111MODULE=on
+ export GOFLAGS=-mod=vendor
+ export CONFFILE=/etc/GeoIP.conf
+ export DATADIR=/usr/share/GeoIP
+ export VERSION=${PV}
+ default
+}
+
+src_install() {
+ mkdir "${D}/usr/bin" -p
+ cd "src/${EGO_PN}/build" || die
+ cp geoipupdate "${D}/usr/bin" || die
+ keepdir /usr/share/GeoIP
+ insinto /etc
+ doins GeoIP.conf
+}