summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-10 16:20:48 +0100
committerSam James <sam@gentoo.org>2023-09-10 16:20:59 +0100
commit878d23322e0a0d119242da7dd193cf34a92e9985 (patch)
treed9a94f88f8537d99b8c07e77e80aff5668721e52 /net-misc/netifrc/netifrc-9999.ebuild
parentdev-python/pikepdf: Bump to 8.4.1 (diff)
downloadgentoo-878d23322e0a0d119242da7dd193cf34a92e9985.tar.gz
gentoo-878d23322e0a0d119242da7dd193cf34a92e9985.tar.bz2
gentoo-878d23322e0a0d119242da7dd193cf34a92e9985.zip
net-misc/netifrc: add 0.7.6
Bug: https://bugs.gentoo.org/889922 Bug: https://bugs.gentoo.org/893290 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/netifrc/netifrc-9999.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index 67e26c8b1ccf..f0edbfcf57dd 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd udev
DESCRIPTION="Gentoo Network Interface Management Scripts"
HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/netifrc.git"
- #EGIT_REPO_URI="https://github.com/gentoo/${PN}" # Alternate
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/netifrc.git
+ https://github.com/gentoo/${PN}
+ "
inherit git-r3
else
SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
@@ -21,13 +23,15 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="+dhcp"
-RDEPEND="sys-apps/gentoo-functions
+RDEPEND="
+ sys-apps/gentoo-functions
>=sys-apps/openrc-0.15
- dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )"
+ dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )
+"
BDEPEND="kernel_linux? ( virtual/pkgconfig )"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
local ver="git-${EGIT_VERSION:0:6}"
sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
einfo "Producing ChangeLog from Git history"