summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-11 04:14:56 +0100
committerSam James <sam@gentoo.org>2023-05-11 04:15:48 +0100
commite4ed427a245eaf0b0d1649cb7cf4bd927e37c706 (patch)
tree8191a028f4fc6633befd96597855b1b147d7ecc5 /net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild
parentx11-misc/fluxter: build w/ c++14 (-Wregister) (diff)
downloadgentoo-e4ed427a245eaf0b0d1649cb7cf4bd927e37c706.tar.gz
gentoo-e4ed427a245eaf0b0d1649cb7cf4bd927e37c706.tar.bz2
gentoo-e4ed427a245eaf0b0d1649cb7cf4bd927e37c706.zip
net-misc/netstat-nat: fix modern C issues
Closes: https://bugs.gentoo.org/875149 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild')
-rw-r--r--net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild b/net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild
new file mode 100644
index 000000000000..3650b7cef189
--- /dev/null
+++ b/net-misc/netstat-nat/netstat-nat-1.4.10-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Display NAT connections"
+HOMEPAGE="http://tweegy.nl/projects/netstat-nat/index.html"
+SRC_URI="http://tweegy.nl/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc sparc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-modern-c.patch
+ "${FILESDIR}"/${P}-docdir.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}