summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-21 17:00:31 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-21 17:00:56 +0100
commit3857c4a8bf1d251fd6b068278cae901afe6043df (patch)
treecf0b5e7760f112c7a0670ffce8b6d2ce2f7d25c8 /net-misc/olsrd/files
parentsys-fs/btrfs-progs: Work around racy Makefile (diff)
downloadgentoo-3857c4a8bf1d251fd6b068278cae901afe6043df.tar.gz
gentoo-3857c4a8bf1d251fd6b068278cae901afe6043df.tar.bz2
gentoo-3857c4a8bf1d251fd6b068278cae901afe6043df.zip
net-misc/olsrd: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/olsrd/files')
-rw-r--r--net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch b/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
new file mode 100644
index 000000000000..0571340e4d03
--- /dev/null
+++ b/net-misc/olsrd/files/olsrd-0.9.0.2-gtk.patch
@@ -0,0 +1,29 @@
+--- a/gui/linux-gtk/Makefile
++++ b/gui/linux-gtk/Makefile
+@@ -2,14 +2,14 @@
+ include $(TOPDIR)/Makefile.inc
+
+ # hardening flags: -fPIE -Wl,-z,now -pie
+-CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -fPIE -Wno-strict-prototypes \
++CFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 gdk-pixbuf-2.0 gtk+-2.0) -fPIE -Wno-strict-prototypes \
+ -Wno-cast-qual
+-CPPFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 gdk-pixbuf-2.0 gtk+-2.0)
+ LDFLAGS += -pie
+ #LDFLAGS += -Wl,--warn-common
+
+
+-LIBS := $(shell pkg-config --libs gtk+-2.0) -lm
++LIBS := $(shell $(PKG_CONFIG) --libs glib-2.0 gdk-pixbuf-2.0 gtk+-2.0) -lm
+
+ # 32/64 cross compilation
+ ifdef M32
+@@ -30,7 +30,7 @@
+ ifeq ($(VERBOSE),0)
+ @echo "[LD] $@"
+ endif
+- $(MAKECMDPREFIX)$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
++ $(MAKECMDPREFIX)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ .PHONY: clean install
+