summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-10-01 19:33:26 +0200
committerPacho Ramos <pacho@gentoo.org>2023-10-01 19:42:24 +0200
commit96efcdc85262ec4d24451652609a144a7e3c43a5 (patch)
treec8b7d9572bb47b5ca4281fede7729c6f3c0c260b /net-misc/r8168
parentx11-themes/fedora-backgrounds: add 39.0.4 (diff)
downloadgentoo-96efcdc85262ec4d24451652609a144a7e3c43a5.tar.gz
gentoo-96efcdc85262ec4d24451652609a144a7e3c43a5.tar.bz2
gentoo-96efcdc85262ec4d24451652609a144a7e3c43a5.zip
net-misc/r8168: add 8.052.01
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/r8168-8.052.01.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index df4b080d77e0..9ead16377f3e 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1 +1,2 @@
DIST r8168-8.051.02.tar.bz2 115969 BLAKE2B 28b809c0330920ee0db7a8f8d41e178882531cd0a6793efeadd9670b1a9b5cbe903061073fd1d461f4234feb41249a244f9ef35cdbb780da498e5a6d6f1a5490 SHA512 2f29a413e7db2b7295ea0a970b3385de1dfd6e41e1820097355687daa5c8d155c1cf6115c72875bff4f366365579bffc81733469a62d76f437065b7e514387ca
+DIST r8168-8.052.01.tar.bz2 126861 BLAKE2B dccee164ea1151859752d525390a3786d31d445e05188a86d2d17c9cbd4435aac788dc5ca1350fcc719bba1c42bd358f39221666f8575d52a9cbf9c78b65c70d SHA512 ae90e108ba3eaaa1c8a639392b21ff98e71abdba514a19b2f286603fbdae69c88592380d9dacda2c10d711348797006a8b518383e4a0519d1bd26dc60266b4b5
diff --git a/net-misc/r8168/r8168-8.052.01.ebuild b/net-misc/r8168/r8168-8.052.01.ebuild
new file mode 100644
index 000000000000..8d93a0a7f5fe
--- /dev/null
+++ b/net-misc/r8168/r8168-8.052.01.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="use-firmware"
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${P} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+src_compile() {
+ local modlist=( ${PN}=kernel/drivers/net/ethernet/realtek:src )
+ local modargs=(
+ # Build parameters
+ KERNELDIR="${KV_OUT_DIR}"
+ # Configuration settings
+ ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)
+ )
+
+ linux-mod-r1_src_compile
+}