summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-17 20:24:31 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-17 21:19:30 +0200
commitddf9ddd2345a3b2b4cd47b2dd0208f7113316c28 (patch)
treeb08d2d1ad392ebfedcf3c9cea5dd7c018a7194c0 /net-misc/rwhoisd
parentnet-im/minbif: drop old version (diff)
downloadgentoo-ddf9ddd2345a3b2b4cd47b2dd0208f7113316c28.tar.gz
gentoo-ddf9ddd2345a3b2b4cd47b2dd0208f7113316c28.tar.bz2
gentoo-ddf9ddd2345a3b2b4cd47b2dd0208f7113316c28.zip
net-misc/rwhoisd: migrate to glep 81
Closes: https://bugs.gentoo.org/781428 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/rwhoisd')
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.6-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.6-r1.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.6-r1.ebuild
new file mode 100644
index 000000000000..f76abd1d3658
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="https://github.com/arineng/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+RDEPEND="
+ acct-group/rwhoisd
+ acct-user/rwhoisd
+"
+
+src_compile() {
+ append-cflags -DNEW_STYLE_BIN_SORT
+
+ emake -C common
+ emake -C regexp
+ emake -C mkdb
+
+ default
+}
+
+src_install() {
+ default
+
+ doinitd "${FILESDIR}"/rwhoisd
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd
+}
+
+pkg_postinst() {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}