summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-04 16:45:45 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-04 16:45:45 +0200
commite8f98c608dacdb97e4f91dca113a70be56b24053 (patch)
tree3a58d57a3f61aafac1e4ed4d6864318b76b0e00f /net-misc/shigofumi/shigofumi-0.9.ebuild
parentnet-misc/seafile: remove redundant WANT_AUTOMAKE=1.16 (diff)
downloadgentoo-e8f98c608dacdb97e4f91dca113a70be56b24053.tar.gz
gentoo-e8f98c608dacdb97e4f91dca113a70be56b24053.tar.bz2
gentoo-e8f98c608dacdb97e4f91dca113a70be56b24053.zip
net-misc/shigofumi: add 0.9
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/shigofumi/shigofumi-0.9.ebuild')
-rw-r--r--net-misc/shigofumi/shigofumi-0.9.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/shigofumi/shigofumi-0.9.ebuild b/net-misc/shigofumi/shigofumi-0.9.ebuild
new file mode 100644
index 000000000000..398763fed882
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-0.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI='https://repo.or.cz/shigofumi.git'
+ inherit autotools git-r3
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug nls xattr"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/libxml2:2
+ net-libs/libisds
+ sys-apps/file
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+[[ ${PV} == *9999 ]] && BDEPEND+="
+ app-text/docbook-xsl-stylesheets
+ app-text/po4a
+ dev-libs/libxslt"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --enable-doc
+ --without-docbook-xsl-stylesheets
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable xattr)
+ )
+ [[ ${PV} == *9999 ]] && myeconfargs+=(
+ --with-docbook-xsl-stylesheets
+ )
+
+ econf "${myeconfargs[@]}"
+}