summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sks/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sks/files')
-rw-r--r--net-misc/sks/files/sks-1.1.5-disable-warn-error-a.patch29
-rw-r--r--net-misc/sks/files/sks-1.1.5-eddsa.patch84
-rw-r--r--net-misc/sks/files/sks-db.initd25
-rw-r--r--net-misc/sks/files/sks-db.service11
-rw-r--r--net-misc/sks/files/sks-recon.initd26
-rw-r--r--net-misc/sks/files/sks-recon.service11
-rw-r--r--net-misc/sks/files/sks.confd4
7 files changed, 190 insertions, 0 deletions
diff --git a/net-misc/sks/files/sks-1.1.5-disable-warn-error-a.patch b/net-misc/sks/files/sks-1.1.5-disable-warn-error-a.patch
new file mode 100644
index 000000000000..18af6c524a22
--- /dev/null
+++ b/net-misc/sks/files/sks-1.1.5-disable-warn-error-a.patch
@@ -0,0 +1,29 @@
+From 5142992b465e87181a4674ac614bf7d2fd7110c4 Mon Sep 17 00:00:00 2001
+From: Kristian Fiskerstrand <kristian.fiskerstrand@sumptuouscapital.com>
+Date: Sun, 26 Jul 2015 21:25:53 +0200
+Subject: [PATCH] (Makefile) Disable warn-error A
+
+warn-error A is set for development versions (tagged with +) upstream,
+however it is not intended to actually be fatal errors for released
+versions. We want to keep EdDSA support, i.e it is actually one
+commit past 1.1.5, so just disabling making warnings fatal.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 543c531..d4a1222 100644
+--- a/Makefile
++++ b/Makefile
+@@ -49,7 +49,7 @@ SKSVS=$(shell grep 'version_suffix = "+"' common.ml)
+ ifeq ($(strip $(SKSVS)),)
+ WARNERR=
+ else
+-WARNERR=-warn-error A
++WARNERR=
+ endif
+
+ CAMLP4=-pp $(CAMLP4O)
+--
+2.3.6
+
diff --git a/net-misc/sks/files/sks-1.1.5-eddsa.patch b/net-misc/sks/files/sks-1.1.5-eddsa.patch
new file mode 100644
index 000000000000..36359f233c49
--- /dev/null
+++ b/net-misc/sks/files/sks-1.1.5-eddsa.patch
@@ -0,0 +1,84 @@
+diff -r 4d5e4fd7c1c2 CHANGELOG
+--- a/CHANGELOG Mon Aug 11 20:56:45 2014 -0500
++++ b/CHANGELOG Tue Feb 03 00:01:20 2015 +0100
+@@ -1,3 +1,7 @@
++Development:
++ - Add support for EdDSA key using Ed25519 signature scheme
++ (http://www.ietf.org/id/draft-koch-eddsa-for-openpgp-00.txt)
++
+ 1.1.5
+ - Fixes for machine-readable indices. Key expiration times are now read
+ from self-signatures on the key's UIDs. In addition, instead of 8-digit
+diff -r 4d5e4fd7c1c2 common.ml
+--- a/common.ml Mon Aug 11 20:56:45 2014 -0500
++++ b/common.ml Tue Feb 03 00:01:20 2015 +0100
+@@ -47,7 +47,7 @@
+ (* for Release versions, COMMONCAMLFLAGS in Makefile should include *)
+ (* '-warn-error a'. Development work should use '-warn-error A' for stricter *)
+ (* language checking. This affects the Ocaml compiler beginning with v4.01.0 *)
+-let version_suffix = "" (* + for development branch *)
++let version_suffix = "+" (* + for development branch *)
+ let compatible_version_tuple = (0,1,5)
+ let version =
+ let (maj_version,min_version,release) = version_tuple in
+diff -r 4d5e4fd7c1c2 packet.ml
+--- a/packet.ml Mon Aug 11 20:56:45 2014 -0500
++++ b/packet.ml Tue Feb 03 00:01:20 2015 +0100
+@@ -163,6 +163,7 @@
+ | 19 -> "ECDSA (ECC)" (* RFC 6637 *)
+ | 20 -> "Elgamal (Encrypt or Sign)"
+ | 21 -> "Reserved for Diffie-Hellman (X9.42) as defined for IETF-S/MIME"
++ | 22 -> "EdDSA"
+ | x when x >= 100 && x <= 110 -> "Private/Experimental algorithm."
+ | _ -> "Unknown Public Key Algorithm"
+
+@@ -252,10 +253,11 @@
+ | 2 -> "r" (* RSA encrypt *)
+ | 3 -> "s" (* RSA sign *)
+ | 16 -> "g" (* ElGamal encrypt *)
+- | 20 -> "G" (* ElGamal sign and encrypt *)
+ | 17 -> "D" (* DSA *)
+ | 18 -> "e" (* ECDH *)
+ | 19 -> "E" (* ECDSA *)
++ | 20 -> "G" (* ElGamal sign and encrypt *)
++ | 22 -> "E" (* EdDSA *)
+ | _ -> "?" (* NoClue *)
+
+ (** writes out packet, using old-style packets when possible *)
+diff -r 4d5e4fd7c1c2 parsePGP.ml
+--- a/parsePGP.ml Mon Aug 11 20:56:45 2014 -0500
++++ b/parsePGP.ml Tue Feb 03 00:01:20 2015 +0100
+@@ -150,6 +150,7 @@
+ | "\x2b\x24\x03\x03\x02\x08\x01\x01\x0b" -> 384 (* brainpoolP384r1 *)
+ | "\x2b\x24\x03\x03\x02\x08\x01\x01\x0d" -> 512 (* brainpoolP512r1 *)
+ | "\x2b\x81\x04\x00\x0a" -> 256 (* secp256k1 *)
++ | "\x2b\x06\x01\x04\x01\xda\x47\x0f\x01" -> 256 (* Ed25519 *)
+ | _ -> failwith "Unknown OID"
+ in
+ psize
+@@ -168,6 +169,7 @@
+ in
+ (mpi, psize)
+
++ (* Algorithm specific fields for ECDSA and EdDSA *)
+ let parse_ecdsa_pubkey cin =
+ let length = cin#read_int_size 1 in
+ let oid = cin#read_string length in
+@@ -185,7 +187,7 @@
+ let algorithm = cin#read_byte in
+ let (tmpmpi, tmpsize) = match algorithm with
+ | 18 -> parse_ecdh_pubkey cin
+- | 19 -> ( {mpi_bits = 0; mpi_data = ""}, (parse_ecdsa_pubkey cin))
++ | 19 | 22 -> ( {mpi_bits = 0; mpi_data = ""}, (parse_ecdsa_pubkey cin))
+ | _ -> ( {mpi_bits = 0; mpi_data = ""} , -1 )
+ in
+ let mpis = match algorithm with
+@@ -205,7 +207,7 @@
+ pk_ctime = creation_time;
+ pk_expiration = (match expiration with Some 0 -> None | x -> x);
+ pk_alg = algorithm;
+- pk_keylen = (match algorithm with |18|19 -> psize | _ -> mpi.mpi_bits);
++ pk_keylen = (match algorithm with |18|19|22 -> psize | _ -> mpi.mpi_bits);
+ }
+
+ (********************************************************)
diff --git a/net-misc/sks/files/sks-db.initd b/net-misc/sks/files/sks-db.initd
new file mode 100644
index 000000000000..93f1561d7eb1
--- /dev/null
+++ b/net-misc/sks/files/sks-db.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+source /etc/conf.d/sks
+
+command=/usr/bin/sks
+command_args="db ${SKS_ARGS}"
+command_background=1
+description="SKS database thread"
+name="SKS db"
+pidfile="/var/run/sks-db.pid"
+required_files="${SKS_DIR}/sksconf"
+start_stop_daemon_args="--chdir ${SKS_DIR} --user sks"
+
+
+depend()
+{
+ use net
+}
+
+start_pre()
+{
+ checkpath --owner sks:sks --directory \
+ ${SKS_DIR} ${SKS_DIR}/KDB ${SKS_DIR}/PTree
+ checkpath --owner sks:sks --file \
+ ${SKS_DIR}/*.log ${SKS_DIR}/KDB/* ${SKS_DIR}/PTree/*
+}
diff --git a/net-misc/sks/files/sks-db.service b/net-misc/sks/files/sks-db.service
new file mode 100644
index 000000000000..bbc3ba7e2b2d
--- /dev/null
+++ b/net-misc/sks/files/sks-db.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=SKS database thread
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/sks db
+User=sks
+WorkingDirectory=/var/lib/sks
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/sks/files/sks-recon.initd b/net-misc/sks/files/sks-recon.initd
new file mode 100644
index 000000000000..be44cb7e3cf7
--- /dev/null
+++ b/net-misc/sks/files/sks-recon.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+source /etc/conf.d/sks
+
+command=/usr/bin/sks
+command_args="recon ${SKS_ARGS}"
+command_background=1
+description="Reconnoiters SKS peers for keys"
+name="SKS recon"
+pidfile="/var/run/sks-recon.pid"
+required_files="${SKS_DIR}/sksconf ${SKS_DIR}/membership"
+start_stop_daemon_args="--chdir ${SKS_DIR} --user sks"
+
+
+depend()
+{
+ after sks-db
+ use net
+}
+
+start_pre()
+{
+ checkpath --owner sks:sks --directory \
+ ${SKS_DIR} ${SKS_DIR}/KDB ${SKS_DIR}/PTree
+ checkpath --owner sks:sks --file \
+ ${SKS_DIR}/*.log ${SKS_DIR}/KDB/* ${SKS_DIR}/PTree/*
+}
diff --git a/net-misc/sks/files/sks-recon.service b/net-misc/sks/files/sks-recon.service
new file mode 100644
index 000000000000..97ee52ffc0ed
--- /dev/null
+++ b/net-misc/sks/files/sks-recon.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=SKS key reconnaissance thread
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/sks recon
+User=sks
+WorkingDirectory=/var/lib/sks
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/sks/files/sks.confd b/net-misc/sks/files/sks.confd
new file mode 100644
index 000000000000..64eef24ecc52
--- /dev/null
+++ b/net-misc/sks/files/sks.confd
@@ -0,0 +1,4 @@
+SKS_DIR="/var/lib/sks"
+
+# Set common options for sks db and sks recon here.
+SKS_ARGS="" \ No newline at end of file