summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-08-25 14:34:36 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-08-25 14:35:01 +0300
commite52475278137a29d678b58350f19822abbc37e9e (patch)
tree0b048a6b353267bb7f1f463a3f88a4aa287ccb31 /net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
parentsys-kernel/hardened-sources: remove 4.6.4-r1 and 4.6.5-r1, bug #589838 (diff)
downloadgentoo-e52475278137a29d678b58350f19822abbc37e9e.tar.gz
gentoo-e52475278137a29d678b58350f19822abbc37e9e.tar.bz2
gentoo-e52475278137a29d678b58350f19822abbc37e9e.zip
net-misc/sstp-client: revision bump
Bump EAPI to 6, fix incorrect handling of user patches in src_prepare Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild')
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild b/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
new file mode 100644
index 000000000000..0853fc6d80c1
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools linux-info multilib user
+
+DESCRIPTION="A client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="http://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+RDEPEND=">=dev-libs/libevent-2.0.10
+ dev-libs/openssl:0
+ net-dialup/ppp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+DOCS=( AUTHORS ChangeLog DEVELOPERS INSTALL NEWS README TODO USING )
+
+pkg_setup() {
+ enewgroup sstpc
+ enewuser sstpc -1 -1 -1 sstpc
+}
+
+src_prepare() {
+ # set proper examples dir, --docdir overriding is src_configure does not work
+ sed -i -e "/^docdir/s:@PACKAGE@:${PF}/examples:" Makefile.am || die 'sed on Makefile.am failed'
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ econf \
+ --enable-ppp-plugin \
+ --enable-group=sstpc \
+ --enable-user=sstpc \
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}" \
+ --with-runtime-dir="/run/sstpc" \
+ $(use_enable static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}