summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Torre <torreemanuele6@gmail.com>2024-08-16 03:42:59 +0200
committerSam James <sam@gentoo.org>2024-08-16 03:18:35 +0100
commitb3cc9b83f14d43717c8841f0180b6f2a6b1720c6 (patch)
tree0aa3d57c5efc2f60fc9e28d73dc49585e9e96284 /net-misc/trurl
parentnet-misc/trurl: add latest 0.14, fix 9999 build (diff)
downloadgentoo-b3cc9b83f14d43717c8841f0180b6f2a6b1720c6.tar.gz
gentoo-b3cc9b83f14d43717c8841f0180b6f2a6b1720c6.tar.bz2
gentoo-b3cc9b83f14d43717c8841f0180b6f2a6b1720c6.zip
net-misc/trurl: drop 0.7
Signed-off-by: Emanuele Torre <torreemanuele6@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38168 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/trurl')
-rw-r--r--net-misc/trurl/Manifest1
-rw-r--r--net-misc/trurl/files/trurl-0.7-fix-makefile.patch21
-rw-r--r--net-misc/trurl/trurl-0.7.ebuild52
3 files changed, 0 insertions, 74 deletions
diff --git a/net-misc/trurl/Manifest b/net-misc/trurl/Manifest
index 71fbfab765ea..0df7a6ebf06b 100644
--- a/net-misc/trurl/Manifest
+++ b/net-misc/trurl/Manifest
@@ -1,2 +1 @@
DIST trurl-0.14.tar.gz 47830 BLAKE2B 15be36ef5c5989cf15d3983827055c793f15ae59efe8e02cc2f55ad9b19c528bb568aacc0583590017a6d6a3a74db1bd6bd3e18d3fee1c7c7d86e71f503d57f7 SHA512 25c1a3035095065368c8a11547e1d918b6f688e293982895a7bc27d9e161c0193ceccfaa0c2440f5c42a8ba4d5176a3f6a4fb843f5fa573328ef9baf5a438165
-DIST trurl-0.7.tar.gz 36624 BLAKE2B a63e8ec7f0b57006b5fa7a1d2ade1284dc2076474ef0425574ecb9b452c49d9a6148461a97e760287340d67a924612c1eb1fe188b6597b8147f818c18681190f SHA512 9ecccd9b688d7bddba760bbd408a1b864d5818b2c538904662ab81b13bca6226d03a4d209c74841c83ee368e656243e92bc7f7be876dbd5c1736b7fc2c3f82d6
diff --git a/net-misc/trurl/files/trurl-0.7-fix-makefile.patch b/net-misc/trurl/files/trurl-0.7-fix-makefile.patch
deleted file mode 100644
index f1ecb28d3aaa..000000000000
--- a/net-misc/trurl/files/trurl-0.7-fix-makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-See https://github.com/curl/trurl/pull/158#issuecomment-1512397801.
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,6 @@
- TARGET = trurl
- OBJS = trurl.o
--LDLIBS = $$(curl-config --libs)
--CFLAGS = $$(curl-config --cflags) -W -Wall -Wshadow -Werror -pedantic -g
-+LDLIBS = $(shell curl-config --libs)
- MANUAL = trurl.1
-
- PREFIX ?= /usr/local
-@@ -12,7 +11,7 @@ INSTALL ?= install
- PYTHON3 ?= python3
-
- $(TARGET): $(OBJS)
-- $(CC) $(OBJS) -o $(TARGET) $(LDLIBS) $(LDFLAGS)
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -Wall $(shell curl-config --cflags) $(LDFLAGS) $(OBJS) -o $(TARGET) $(LDLIBS)
-
- trurl.o:trurl.c version.h
-
diff --git a/net-misc/trurl/trurl-0.7.ebuild b/net-misc/trurl/trurl-0.7.ebuild
deleted file mode 100644
index 2a3befe7c83d..000000000000
--- a/net-misc/trurl/trurl-0.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Command line tool for URL parsing and manipulation"
-HOMEPAGE="https://curl.se/trurl/ https://daniel.haxx.se/blog/2023/04/03/introducing-trurl/"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/curl/trurl"
- inherit git-r3
-else
- SRC_URI="https://github.com/curl/trurl/archive/refs/tags/${P}.tar.gz"
- S="${WORKDIR}"/${PN}-${P}
-
- KEYWORDS="~amd64 ~arm ~arm64"
-fi
-
-LICENSE="curl"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Older curls may work but not all features will be present
-DEPEND=">=net-misc/curl-7.81.0"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7-fix-makefile.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_compile() {
- tc-export CC
-
- default
-}
-
-src_test() {
- emake PYTHON3="${EPYTHON}" test
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
-}