summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 00:17:09 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 00:38:01 -0400
commit0491a4264baf9951dd726b96094459a7b3363b95 (patch)
treeec64d78afa8d2e44098854827bb7742fa6f42994 /net-misc/vncrec
parentdev-libs/wayland-protocols: Version bump to 1.27 (diff)
downloadgentoo-0491a4264baf9951dd726b96094459a7b3363b95.tar.gz
gentoo-0491a4264baf9951dd726b96094459a7b3363b95.tar.bz2
gentoo-0491a4264baf9951dd726b96094459a7b3363b95.zip
net-misc/vncrec: further fix w/ upcoming clang16
When last tested this package, did not know clang16 was newly enabling -Werror=incompatible-pointer-types yet and hadn't looked at this. Bit dodgy here given we don't know what the X11 headers want, i.e. _X_NORETURN could be set or not set, and an update could remove it from XtErrorhandler entirely (so passing it may break later) -- so pass -Wno-error instead (should be harmless in this case). Bug: https://bugs.gentoo.org/871000 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/vncrec')
-rw-r--r--net-misc/vncrec/vncrec-0.2-r3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-misc/vncrec/vncrec-0.2-r3.ebuild b/net-misc/vncrec/vncrec-0.2-r3.ebuild
index e3295a4579be..66d88e91b811 100644
--- a/net-misc/vncrec/vncrec-0.2-r3.ebuild
+++ b/net-misc/vncrec/vncrec-0.2-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="VNC session recorder and player"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -42,6 +42,11 @@ src_prepare() {
}
src_configure() {
+ # XtErrorHandler usage matches docs (seems right), but headers "may" add
+ # __attribute__((noreturn)) giving an incompatible type error with clang-16
+ # (could alternatively use private _X_NORETURN but this may be fragile).
+ append-cflags -Wno-error=incompatible-function-pointer-types #871000
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}