summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-12-02 01:49:55 +0100
committerSam James <sam@gentoo.org>2024-12-02 14:48:28 +0000
commit1085b07762f2c16150d0b2cae4b3aecd12290fa8 (patch)
tree1a8e2e43bf54ea0ee8bbaaed1794c795d4f0d5c6 /net-misc
parentdev-python/tpm2-pytss: drop 2.2.1 (diff)
downloadgentoo-1085b07762f2c16150d0b2cae4b3aecd12290fa8.tar.gz
gentoo-1085b07762f2c16150d0b2cae4b3aecd12290fa8.tar.bz2
gentoo-1085b07762f2c16150d0b2cae4b3aecd12290fa8.zip
net-misc/tinyssh: add 20241201
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/39549 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tinyssh/Manifest1
-rw-r--r--net-misc/tinyssh/tinyssh-20241201.ebuild60
-rw-r--r--net-misc/tinyssh/tinyssh-99999999.ebuild14
3 files changed, 62 insertions, 13 deletions
diff --git a/net-misc/tinyssh/Manifest b/net-misc/tinyssh/Manifest
index ba2bf36ba47a..5d99373317d1 100644
--- a/net-misc/tinyssh/Manifest
+++ b/net-misc/tinyssh/Manifest
@@ -1 +1,2 @@
DIST tinyssh-20241111.tar.gz 263324 BLAKE2B 81fbf6b3af4f6ef72acf1a339c4b0b6e7dce0aa3afee4947aa93ac45120836ff0febcf13dcbaea43be0dc4eb1e80c47a0a3b7dcfc8e4b00ad6577c1b366593ae SHA512 52716b6f8998f41180080a33cce0bcb3ff5eb1648b4c61b9ff99c3070f95c1900ab62bc23b30353905d146d557b2550b393c940f25a51d174648951cbc7ec2fc
+DIST tinyssh-20241201.tar.gz 301611 BLAKE2B de8a7cabecc9ab134adfb5e7e2eba840c47901b9d7720650f6421e4a130447784a66bb9033ab50ecc204966095ebc3cb02d9de18aef5ed0f8f4befdb6af189a2 SHA512 aa0641f92209bce1f1842c13338a053b3d46510280e891d94d7ec48304b621a4fd116abe7e46ad366ee894461e0f8db1e0458db82170622487868cdf4fdb8c66
diff --git a/net-misc/tinyssh/tinyssh-20241201.ebuild b/net-misc/tinyssh/tinyssh-20241201.ebuild
new file mode 100644
index 000000000000..a4aed4b70c61
--- /dev/null
+++ b/net-misc/tinyssh/tinyssh-20241201.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="A small SSH server with state-of-the-art cryptography"
+HOMEPAGE="https://tinyssh.org"
+if [[ "${PV}" == "99999999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/janmojzis/tinyssh.git"
+else
+ SRC_URI="https://github.com/janmojzis/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+
+RDEPEND="
+ ${DEPEND}
+ sys-apps/ucspi-tcp
+"
+
+src_prepare() {
+ default
+
+ echo 'gentoo-autoheaders: $(AUTOHEADERS)' >> Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ emake gentoo-autoheaders
+
+ local i
+ for i in has*.log
+ do
+ einfo "$i"
+ cat "$i"
+ done
+}
+
+src_install() {
+ einstalldocs
+ emake install DESTDIR="${D}" PREFIX=/usr
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ systemd_newunit "${FILESDIR}/${PN}.service" "${PN}@.service"
+ systemd_newunit "${FILESDIR}/${PN}.socket" "${PN}@.socket"
+ systemd_dounit "${FILESDIR}/${PN}-makekey.service"
+}
+
+pkg_postinst() {
+ einfo "TinySSH is in beta stage, and ready for production use."
+ einfo "See https://tinyssh.org for more information."
+}
diff --git a/net-misc/tinyssh/tinyssh-99999999.ebuild b/net-misc/tinyssh/tinyssh-99999999.ebuild
index e1c07e90c588..a4aed4b70c61 100644
--- a/net-misc/tinyssh/tinyssh-99999999.ebuild
+++ b/net-misc/tinyssh/tinyssh-99999999.ebuild
@@ -18,11 +18,6 @@ fi
LICENSE="CC0-1.0"
SLOT="0"
-IUSE="+sodium"
-
-DEPEND="
- sodium? ( dev-libs/libsodium:= )
-"
RDEPEND="
${DEPEND}
sys-apps/ucspi-tcp
@@ -35,14 +30,7 @@ src_prepare() {
}
src_configure() {
- tc-export PKG_CONFIG CC
-
- if use sodium
- then
- # -I${includedir}/sodium needed as tinyssh uses `#include <randombytes.h>` rather than `#include <sodium.h>`
- export CFLAGS="${CFLAGS} $("${PKG_CONFIG}" --cflags libsodium) -I$("${PKG_CONFIG}" --variable=includedir libsodium)/sodium/"
- export LDFLAGS="${LDFLAGS} $("${PKG_CONFIG}" --libs libsodium)"
- fi
+ tc-export CC
emake gentoo-autoheaders