summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2022-07-16 14:25:12 -0500
committerJory Pratt <anarchy@gentoo.org>2022-07-16 14:25:28 -0500
commit27ae28965c47b7886639878c8a1f9b9894df8c74 (patch)
tree8eecdef196f65ba54ab5bf81c518e3efe1d64663 /net-misc
parentapp-misc/graphlcd-base: drop support for imagemagick (diff)
downloadgentoo-27ae28965c47b7886639878c8a1f9b9894df8c74.tar.gz
gentoo-27ae28965c47b7886639878c8a1f9b9894df8c74.tar.bz2
gentoo-27ae28965c47b7886639878c8a1f9b9894df8c74.zip
net-misc/spice-gtk: Fix build for musl users
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.40-r1.ebuild6
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.40.ebuild6
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.41.ebuild6
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild6
4 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.40-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.40-r1.ebuild
index 8da12e589470..7c0c5337eb30 100644
--- a/net-misc/spice-gtk/spice-gtk-0.40-r1.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.40-r1.ebuild
@@ -117,6 +117,12 @@ src_configure() {
$(meson_feature wayland wayland-protocols)
)
+ if use elibc_musl; then
+ emesonargs+=(
+ -Dcoroutine=gthread
+ )
+ fi
+
if use usbredir; then
emesonargs+=(
-Dusb-acl-helper-dir=/usr/libexec
diff --git a/net-misc/spice-gtk/spice-gtk-0.40.ebuild b/net-misc/spice-gtk/spice-gtk-0.40.ebuild
index 357e2deefa6d..650b692b3d89 100644
--- a/net-misc/spice-gtk/spice-gtk-0.40.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.40.ebuild
@@ -112,6 +112,12 @@ src_configure() {
$(meson_feature wayland wayland-protocols)
)
+ if use elibc_musl; then
+ emesonargs+=(
+ -Dcoroutine=gthread
+ )
+ fi
+
if use usbredir; then
emesonargs+=(
-Dusb-acl-helper-dir=/usr/libexec
diff --git a/net-misc/spice-gtk/spice-gtk-0.41.ebuild b/net-misc/spice-gtk/spice-gtk-0.41.ebuild
index 25cd89438ad6..4f9503f25b0d 100644
--- a/net-misc/spice-gtk/spice-gtk-0.41.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.41.ebuild
@@ -112,6 +112,12 @@ src_configure() {
$(meson_feature wayland wayland-protocols)
)
+ if use elibc_musl; then
+ emesonargs+=(
+ -Dcoroutine=gthread
+ )
+ fi
+
if use usbredir; then
emesonargs+=(
-Dusb-acl-helper-dir=/usr/libexec
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index 25cd89438ad6..4f9503f25b0d 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -112,6 +112,12 @@ src_configure() {
$(meson_feature wayland wayland-protocols)
)
+ if use elibc_musl; then
+ emesonargs+=(
+ -Dcoroutine=gthread
+ )
+ fi
+
if use usbredir; then
emesonargs+=(
-Dusb-acl-helper-dir=/usr/libexec