summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-10 22:42:46 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-11 00:17:59 +0100
commit7a851aa0ad9b0929976451691e6de9fd51028dd7 (patch)
tree2cd71bacb375fd5266c7eed85f6f8b4b97174b12 /net-misc
parentnet-misc/gallery-dl: drop old 1.24.0 (diff)
downloadgentoo-7a851aa0ad9b0929976451691e6de9fd51028dd7.tar.gz
gentoo-7a851aa0ad9b0929976451691e6de9fd51028dd7.tar.bz2
gentoo-7a851aa0ad9b0929976451691e6de9fd51028dd7.zip
net-misc/gallery-dl: bump to 1.24.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.24.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index d708df6a90ed..dba1421069c8 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -2,3 +2,4 @@ DIST gallery-dl-1.23.3.gh.tar.gz 488200 BLAKE2B 88482c7f41da00447b6eeb6331d61f6c
DIST gallery-dl-1.23.5.gh.tar.gz 491336 BLAKE2B 6690444508af66f1293f773f2795aae1546e1ce2daf4bedef32fa7aa801d0d6ce82b2825e008a6db7e2e8e6e6c4bce095f0a453cfd23d7ae9ebf09a717b8d07e SHA512 541d1452e55e58a319e3c2523d81d190b2c348c798977d32c091118f5f2eb6a930e27b0029900d98a9cb731e86c43c3fd8e0121fe4caf05db4296c15c8637194
DIST gallery-dl-1.24.1.gh.tar.gz 504352 BLAKE2B 52b5cc5022e74a9453e378c65d6f42216362531c1b3afac7ddf5a87b8e78acbe629e302e08b8273dcad6e25738c0009bd2e197d4cb6fee2bffdd9e20e9d7a296 SHA512 65e00b7d7d6f959f3aa62701b683ce6d6ca30c23f9e0f82c206ed102746b8627bf88f89d5f54bbd4afd4135ddf143a9da1ba05c202f82c114cac1cb926b41efc
DIST gallery-dl-1.24.2.gh.tar.gz 509230 BLAKE2B e0be565c00d4c81b613bdc3fe9983a5a7cc7a1f131750ec79f16e3b38d134f49ef8fb8f9585767c1abdb3c3d3abc4681f5546460373d53da0646f7fd73a3d47b SHA512 2b8780d9ebf868635f76315a5f7a426ed72b4db4e7a12f97ebc86520fa6d5908f39fb26e876cbc46e8249b083f3bf5dc4d38a3c2ddb27873c473c80bac0af415
+DIST gallery-dl-1.24.3.gh.tar.gz 518417 BLAKE2B 2d5c2167b5af9d3aa8c9a65ac0758e336315377fa2bd9a33b977e01360ab45a573f998fd3dccfb15e20a717e9d80acab8b17787ccd7e2141fad9dcd38ff63c94 SHA512 f971944048143ee8c63d3d2161b27f5e1d294b9edcf5155479687eeec279cf8a7fc6a722b4572cab8b741067f73afa06d7895ed1a99396d7a37dd6fb2e929d6e
diff --git a/net-misc/gallery-dl/gallery-dl-1.24.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.24.3.ebuild
new file mode 100644
index 000000000000..7ca6465716ee
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.24.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}