summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-04-15 20:53:51 +0000
committerMatthew Smith <matthew@gentoo.org>2024-04-15 20:54:06 +0000
commitbd80e49457a8d2ae823f8c1fd9329733cfdf7c6e (patch)
tree8aa6694be9c146864631f464d801e00f376ef852 /net-misc
parentdev-build/ninja: add 1.12.0 (diff)
downloadgentoo-bd80e49457a8d2ae823f8c1fd9329733cfdf7c6e.tar.gz
gentoo-bd80e49457a8d2ae823f8c1fd9329733cfdf7c6e.tar.bz2
gentoo-bd80e49457a8d2ae823f8c1fd9329733cfdf7c6e.zip
net-misc/putty: add 0.81
Bug: https://bugs.gentoo.org/930082 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/putty/Manifest1
-rw-r--r--net-misc/putty/putty-0.81.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index beb1f064be86..8e8ee4148932 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,2 +1,3 @@
DIST putty-0.80.tar.gz 2831433 BLAKE2B 95769ed372ee57f1cd0b9c9b26aab47c710b3eac2dd2f40b511179f1e06dae6c59ef5fd270eddc6b0531d8ed135897490ea029e0ca8c1febefe64743ddada341 SHA512 c8a6b6fa54ecd8bcf4ec274fef51343dd9996e6458b250b5555c4dc88ded25e87f97277da482c29858510e65635112d541f559ab683635bd950572d850129f90
+DIST putty-0.81.tar.gz 2844616 BLAKE2B f4f687555ae6d043f9eb868eccb1086227a0fa3ec1a5eff68ab7ccd96c877fd87afad9c9639930e899e0fc16058ea0f4553a3035ab477761038d6257332d64af SHA512 d86f2fd0e126b18275d58cf64334b3b27c450899a1c2be2502de9faa2ef58f7fc8efc5d45f25c8395623f1e21917aa02407343bb2fee44c4c00b9f81267d5ecd
DIST putty-icons.tar.bz2 4878 BLAKE2B 589f1bace82e3fd202b70bd35661d2ec4ef383363f8ae6716d4a6828bd822ef624b0acde39354d3d837e2d2bb49a34dbb89e031c64c520cbc675cad79813acff SHA512 4e419a71e26770e159221f6b516e7210d29272917b4b9a9e0b67c72e73508b97278e56c82111b02e106c5d513c2561fec6da372b4b18246f29372ae618ff5f71
diff --git a/net-misc/putty/putty-0.81.ebuild b/net-misc/putty/putty-0.81.ebuild
new file mode 100644
index 000000000000..777cb2365198
--- /dev/null
+++ b/net-misc/putty/putty-0.81.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake desktop xdg-utils
+
+DESCRIPTION="A Free Telnet/SSH Client"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${PN}-icons.tar.bz2"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.tartarus.org/simon/putty.git"
+else
+ SRC_URI+=" https://the.earth.li/~sgtatham/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+LICENSE="MIT"
+
+SLOT="0"
+IUSE="debug doc +gtk gssapi"
+
+RDEPEND="
+ !net-misc/pssh
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ gssapi? ( virtual/krb5 )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ doc? ( app-text/halibut )
+"
+
+src_unpack() {
+ [[ ${PV} == *9999 ]] && git-r3_src_unpack
+ default
+}
+
+src_configure() {
+ cd "${S}"/unix || die
+ local mycmakeargs=(
+ -DPUTTY_DEBUG="$(usex debug)"
+ -DPUTTY_GSSAPI="$(usex gssapi DYNAMIC OFF)"
+ -DPUTTY_GTK_VERSION=$(usex gtk 3 '')
+ -DPUTTY_IPV6=yes
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile all doc
+}
+
+src_install() {
+ cmake_src_install
+
+ doman "${BUILD_DIR}"/doc/*.1
+
+ if use doc ; then
+ docinto html
+ dodoc "${BUILD_DIR}"/doc/html/*.html
+ fi
+
+ if use gtk ; then
+ local i
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s ${i} \
+ "${WORKDIR}"/${PN}-icons/${PN}-${i}.png \
+ ${PN}.png
+ done
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ make_desktop_entry ${PN} PuTTY ${PN} Network
+ fi
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}