summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-18 12:04:48 +0200
committerSam James <sam@gentoo.org>2021-06-18 12:26:30 +0100
commit2d4a9bbe950fbbdc14cf7b19d86dbbd200b0bed5 (patch)
tree61416ccb4b939fb143a0164e253ff27c23699cbf /net-p2p/litecoind/files
parentsys-kernel/vanilla-sources: Automated version bump to {5.4.127,5.10.45,5.12.1... (diff)
downloadgentoo-2d4a9bbe950fbbdc14cf7b19d86dbbd200b0bed5.tar.gz
gentoo-2d4a9bbe950fbbdc14cf7b19d86dbbd200b0bed5.tar.bz2
gentoo-2d4a9bbe950fbbdc14cf7b19d86dbbd200b0bed5.zip
net-p2p/litecoind: add 0.18.1
Closes: https://bugs.gentoo.org/607842 Bug: https://bugs.gentoo.org/672326 Bug: https://bugs.gentoo.org/768768 Bug: https://bugs.gentoo.org/788844 Signed-off-by: David Seifert <soap@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/litecoind/files')
-rw-r--r--net-p2p/litecoind/files/litecoind-0.18.1-system-leveldb.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/litecoind/files/litecoind-0.18.1-system-leveldb.patch b/net-p2p/litecoind/files/litecoind-0.18.1-system-leveldb.patch
new file mode 100644
index 000000000000..d00748a584fc
--- /dev/null
+++ b/net-p2p/litecoind/files/litecoind-0.18.1-system-leveldb.patch
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -894,10 +894,22 @@
+ [AC_MSG_ERROR([Cannot set default symbol visibility. Use --disable-reduce-exports.])])
+ fi
+
++dnl Check for leveldb, only if explicitly requested
+ LEVELDB_CPPFLAGS=
+ LIBLEVELDB=
+ LIBMEMENV=
+-AM_CONDITIONAL([EMBEDDED_LEVELDB],[true])
++AC_ARG_WITH([system-leveldb],
++ [AS_HELP_STRING([--with-system-leveldb],
++ [Build with system LevelDB (default is no; DANGEROUS; NOT SUPPORTED)])],
++ [system_leveldb=$withval],
++ [system_leveldb=no]
++)
++if test x$system_leveldb != xno; then
++ LEVELDB_CPPFLAGS=
++ LIBLEVELDB=-lleveldb
++ LIBMEMENV=-lmemenv
++fi
++AM_CONDITIONAL([EMBEDDED_LEVELDB],[test x$system_leveldb = xno])
+ AC_SUBST(LEVELDB_CPPFLAGS)
+ AC_SUBST(LIBLEVELDB)
+ AC_SUBST(LIBMEMENV)
+--- a/src/dbwrapper.cpp
++++ b/src/dbwrapper.cpp
+@@ -10,7 +10,7 @@
+ #include <leveldb/cache.h>
+ #include <leveldb/env.h>
+ #include <leveldb/filter_policy.h>
+-#include <memenv.h>
++#include <leveldb/helpers/memenv.h>
+ #include <stdint.h>
+ #include <algorithm>
+