summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorxbt573 <cheembox573@gmail.com>2023-12-22 21:58:01 +0300
committerSam James <sam@gentoo.org>2024-01-14 04:03:26 +0000
commit0a7cfd163f08f3fd2f573c35d2861d2d09b1e113 (patch)
treec54de66835938662e9f8e91e1326828faa74ff48 /net-p2p
parentnet-libs/mbedtls: fix testsuite failures (diff)
downloadgentoo-0a7cfd163f08f3fd2f573c35d2861d2d09b1e113.tar.gz
gentoo-0a7cfd163f08f3fd2f573c35d2861d2d09b1e113.tar.bz2
gentoo-0a7cfd163f08f3fd2f573c35d2861d2d09b1e113.zip
net-p2p/qbittorrent: add 4.6.2, drop proxied maintainer
Signed-off-by: xbt573 <cheembox573@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/metadata.xml9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.6.2.ebuild131
3 files changed, 133 insertions, 8 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index b73321d9d11c..52f42a22b3b8 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -3,3 +3,4 @@ DIST qbittorrent-4.5.4.tar.gz 8791236 BLAKE2B 70b3194d6c4819655998406e0a13d22f3a
DIST qbittorrent-4.5.5.tar.gz 8802492 BLAKE2B 1d20d7900b5b65603c5cf13452fb5aebe396473290d4904641b78867c5345d783482c46edc7042a2e86e79afd790e8c470df62131595eba288f195cc5e716eec SHA512 8b5c2654b3bc03c0b4de77e8388ee543c3892ef9453749ea737aaee999a16d50bd1b30ebe0519a86d7ab8ffc6224d7d9cf678464aebf96433cd71dd57b46dd53
DIST qbittorrent-4.6.0.tar.gz 9024538 BLAKE2B 5addeee21c9a5f05ca4b33a908c6480948dd22cc03524baf8f06429c2f1abb3c88115a53d434023e379561dda27ae43336068071c7f92949c550f6f8b4336a87 SHA512 217b3efe9c8e98eb5c9457d9aede91034b27f85a57ff93d57f51485b5224e85c63b51645b3f5126a51e48894d5065ed2ae3929dcabfcbbe6b036270286ffef3a
DIST qbittorrent-4.6.1.tar.gz 9054911 BLAKE2B ace2f102f21287d7005fdd383bd44bed17894ad370ec7782684669f07c537e0c773acc90e89105794c02c023a4116dbe00fc99ba4ffae49c18159854baca9e5d SHA512 ed6db8174562cd2b96fec1e0c1532a65507cb7034841c9424f654a33866cbf9edc5974f101f0c01cd6c8fd7d76380b4252c4a804ee9776b34ec8ad1b386bdcd1
+DIST qbittorrent-4.6.2.tar.gz 9058275 BLAKE2B b55de1ab7cd08fe4ee6d89eb269b884abea6cb478cc65f74a8e2f718f16919248d7e7cf01f10b5c4065d978d5ad906a60320c336a5cda8beeae7d4fe8cc6c25d SHA512 04977ae048a7f377b5d6a3091b93bbb84b085be9fb48a4096104fd00b77aaf41c8e62f6b527e69a92ce2ab604e95a91222d5f286b9219d094777833c302418e4
diff --git a/net-p2p/qbittorrent/metadata.xml b/net-p2p/qbittorrent/metadata.xml
index 14e773c514d6..19959dc50cd8 100644
--- a/net-p2p/qbittorrent/metadata.xml
+++ b/net-p2p/qbittorrent/metadata.xml
@@ -1,14 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>cheembox573@gmail.com</email>
- <name>Alexey Lunev</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<use>
<flag name="webui">
Install qBittorrent Web UI (qbittorrent-nox) and systemd/OpenRC service
diff --git a/net-p2p/qbittorrent/qbittorrent-4.6.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.6.2.ebuild
new file mode 100644
index 000000000000..f8129fff3348
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.6.2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake edo multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/qBittorrent-release-${PV}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui qt6 systemd test webui"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( gui webui )"
+
+RDEPEND="
+ acct-group/qbittorrent
+ acct-user/qbittorrent
+ >=dev-libs/openssl-1.1.1:=
+ >=net-libs/libtorrent-rasterbar-1.2.18:=
+ >=sys-libs/zlib-1.2.11
+ qt6? ( dev-qt/qtbase:6[network,ssl,sql,sqlite,xml] )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtxml:5
+ )
+ gui? (
+ !qt6? (
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dbus? ( dev-qt/qtdbus:5 )
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus?,gui,widgets]
+ dev-qt/qtsvg:6
+ )
+ )"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+ test? (
+ !qt6? ( dev-qt/qttest:5 )
+ )"
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+ -DQT6=$(usex qt6)
+ -DWEBUI=$(usex webui)
+ -DTESTING=$(usex test)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == "gui" ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ my_src_test() {
+ cd "${BUILD_DIR}"/test || die
+ edo ctest .
+ }
+
+ multibuild_foreach_variant my_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+}