summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 20:08:57 +0100
committerSam James <sam@gentoo.org>2022-04-17 20:17:03 +0100
commit97a2897ad33a755b3dd44f66c27815662580762a (patch)
tree2c64c3c731da93ecf78ba97b529061a7a92ab9e5 /net-p2p
parentnet-nntp/tin: drop 2.6.0 (diff)
downloadgentoo-97a2897ad33a755b3dd44f66c27815662580762a.tar.gz
gentoo-97a2897ad33a755b3dd44f66c27815662580762a.tar.bz2
gentoo-97a2897ad33a755b3dd44f66c27815662580762a.zip
net-p2p/bittornado: drop 0.4.1_p20160925-r2, 0.4.1_p20160925-r3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r2.ebuild51
-rw-r--r--net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild57
2 files changed, 0 insertions, 108 deletions
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r2.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r2.ebuild
deleted file mode 100644
index 6e1e4c3b8599..000000000000
--- a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_7 python3_8 )
-
-inherit distutils-r1
-
-MY_PN=BitTornado
-MY_P=${MY_PN}-${PV}
-EGIT_COMMIT="ed327c4e1ebbe1fe949be81723527cfda87aeb8d"
-
-DESCRIPTION="John Hoffman's fork of the original bittorrent"
-HOMEPAGE="https://github.com/effigies/BitTornado"
-SRC_URI="https://github.com/effigies/BitTornado/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
-# GPL-2 is just for the init script from FILESDIR.
-LICENSE="MIT GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pycryptodome[${PYTHON_USEDEP}]"
-# Block dev-python/pytest-testmon for bug #693508.
-DEPEND="test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- !!dev-python/pytest-testmon
-)"
-
-S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
-
-python_prepare_all() {
- # https://github.com/effigies/BitTornado/pull/53
- sed -e 's:"BitTornado.Tracker":\0, "BitTornado.Types":' -i setup.py || die
- find "${S}" -name '*.py' -print0 | xargs --null -- sed -i 's:time.clock():time.perf_counter():g' || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v BitTornado/tests || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newconfd "${FILESDIR}"/bttrack.conf bttrack
- newinitd "${FILESDIR}"/bttrack.rc bttrack
-}
diff --git a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild b/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
deleted file mode 100644
index d345a1be9903..000000000000
--- a/net-p2p/bittornado/bittornado-0.4.1_p20160925-r3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-MY_PN=BitTornado
-MY_P=${MY_PN}-${PV}
-EGIT_COMMIT="ed327c4e1ebbe1fe949be81723527cfda87aeb8d"
-
-DESCRIPTION="John Hoffman's fork of the original bittorrent"
-HOMEPAGE="https://github.com/effigies/BitTornado"
-SRC_URI="https://github.com/effigies/BitTornado/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
-# GPL-2 is just for the init script from FILESDIR.
-LICENSE="MIT GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pycryptodome[${PYTHON_USEDEP}]
-"
-# Block dev-python/pytest-testmon for bug #693508.
-DEPEND="
- test? (
- !!dev-python/pytest-testmon
- )
-"
-
-S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # https://github.com/effigies/BitTornado/pull/53
- sed -e 's:"BitTornado.Tracker":\0, "BitTornado.Types":' -i setup.py || die
- find "${S}" -name '*.py' -print0 | \
- xargs --null -- \
- sed -r -i 's:time.clock():time.perf_counter():g ; s:collections.(MutableSet|Set|Sequence|Mapping):collections.abc.\1:g' || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest BitTornado/tests
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newconfd "${FILESDIR}"/bttrack.conf bttrack
- newinitd "${FILESDIR}"/bttrack.rc bttrack
-}