summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-07-01 10:34:23 -0400
committerCraig Andrews <candrews@gentoo.org>2024-07-01 10:42:04 -0400
commitdc39353be6e21049abfc271f986c86ca3e8ce58a (patch)
tree29e0742aa00c53269ab55730395c400420197c81 /net-p2p
parentwww-apps/lidarr-bin: drop 2.4.0.4222 (diff)
downloadgentoo-dc39353be6e21049abfc271f986c86ca3e8ce58a.tar.gz
gentoo-dc39353be6e21049abfc271f986c86ca3e8ce58a.tar.bz2
gentoo-dc39353be6e21049abfc271f986c86ca3e8ce58a.zip
net-p2p/cpuminer-opt: add 24.4
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-24.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 01c582369956..5ac76e8714fd 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-24.3.tar.gz 1791024 BLAKE2B 7b563f48f2170dd73cd790243bf5b2043cee85f8f25655f805f2c0aeba96e580047cdb10a6a8bda4a2942a8417a1422dd884aebd9593f0b1b0cd0ed9cb4ceb53 SHA512 4ba7043b5226d2cef8fd25044942b01245c8ae7c9088e7b1e07f115b4f6592e2746cd2261a123d94344f81c12f4ceb897579ebbfa048569779f9cd5ee65d9c50
+DIST cpuminer-opt-24.4.tar.gz 1787907 BLAKE2B 73f1da98f64ab7048f12d22f16ea2c94e2a0059a941d161d7c3e9721d13e7e018e0c98486f969270b1de580077ea8cd188f6b88e1f3a61b71c4f5626b43f7100 SHA512 e3648726ebd528d79c0d5f89fdf2affa1629fef0a28c7bccc6c3fdc76bac2c5ce8db9e36ccc0f1c6e3bf4f663cf15dd06d7130a6dbb205f3ab55ac675a6bac77
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-24.4.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-24.4.ebuild
new file mode 100644
index 000000000000..2683d4bdc544
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-24.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ newins config-template.json cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}