summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-30 17:41:59 +0100
committerSam James <sam@gentoo.org>2023-03-30 17:42:04 +0100
commitab52eae418c23d9ca85e40458f1ef0b15be784ec (patch)
tree7835ebecbdc796449320ba0444a26dea0a4d242a /net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild
parentnet-misc/connman: Stabilize 1.42_pre20230116-r2 ppc64, #903599 (diff)
downloadgentoo-ab52eae418c23d9ca85e40458f1ef0b15be784ec.tar.gz
gentoo-ab52eae418c23d9ca85e40458f1ef0b15be784ec.tar.bz2
gentoo-ab52eae418c23d9ca85e40458f1ef0b15be784ec.zip
net-print/lexmark-upd-ppd: add 1.0.0.20220702, drop 1.0.0.20210304
Contents are the same. Closes: https://bugs.gentoo.org/855632 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild')
-rw-r--r--net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild b/net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild
new file mode 100644
index 000000000000..41b1efe01e00
--- /dev/null
+++ b/net-print/lexmark-upd-ppd/lexmark-upd-ppd-1.0.0.20220702.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Lexmark universal printer driver PPDs"
+HOMEPAGE="https://www.lexmark.com/en_us/support/universal-print-driver.html"
+SRC_URI="https://downloads.lexmark.com/downloads/drivers/Lexmark-UPD-PPD-Files.tar.Z -> ${P}.tar.Z"
+RESTRICT="mirror"
+
+LICENSE="Lexmark-EU2-0111"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="
+ >=net-print/cups-1.4
+ net-dns/avahi
+"
+BDEPEND=""
+
+# TODO: add IUSE for foomatic and install those files too
+
+S="${WORKDIR}"/ppd_files
+
+QA_FLAGS_IGNORED="usr/libexec/cups/filter/LexCommandFileFilterG2"
+
+src_prepare() {
+ default
+ sed -i 's:/usr/lib/cups/filter/:/usr/libexec/cups/filter/:g' GlobalPPD_1.4/Lexmark_UPD_Series.ppd || die "Unable to patch hard coded PPD paths"
+}
+
+src_install() {
+ local filterdir
+ if use amd64; then filterdir="lib64";
+ elif use x86; then filterdir="lib";
+ else die "No filter for architecture"; fi
+
+ insinto /usr/share/cups/model
+ exeinto /usr/libexec/cups/filter
+
+ doins "${S}"/GlobalPPD_1.4/Lexmark_UPD_Series.ppd
+ doexe "${S}"/GlobalPPD_1.4/$filterdir/LexCommandFileFilterG2
+ doexe "${S}"/GlobalPPD_1.4/LexFaxPnHFilter
+}