summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-18 13:38:12 +0100
committerSam James <sam@gentoo.org>2024-10-18 13:38:12 +0100
commit9629abcaefcca7b783c2afcd5a3f530779e34256 (patch)
tree2846adcf3b92d5c20d7a323f0ae6059d4f6d3144 /net-print
parentmedia-gfx/gimp: gimp-2.10.x, fix media-libs/libheif-1.18 compat (diff)
downloadgentoo-9629abcaefcca7b783c2afcd5a3f530779e34256.tar.gz
gentoo-9629abcaefcca7b783c2afcd5a3f530779e34256.tar.bz2
gentoo-9629abcaefcca7b783c2afcd5a3f530779e34256.zip
net-print/libppd: add 2.1.0
Tagging the bug for completeness but we'd already backported the CVE fixes. Bug: https://bugs.gentoo.org/940314 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/libppd/Manifest1
-rw-r--r--net-print/libppd/libppd-2.1.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-print/libppd/Manifest b/net-print/libppd/Manifest
index 164c5dbf1ac4..320b7f82e169 100644
--- a/net-print/libppd/Manifest
+++ b/net-print/libppd/Manifest
@@ -1,2 +1,3 @@
DIST libppd-2.0.0.tar.xz 580716 BLAKE2B 8505c5ab5b515104308624a8f78505343b894df08ab8ac2727d7bd82d0d65d256d22ecaf384b212d9a5c45d2a619a6311722a8c5ed954b7a8a9780477aedb458 SHA512 8be9e67552528606fd804ba13b05710938ed7d02316c1c902ee657bc0e5fade663ffacb5b032609a1c1fdc80d976e7e54d2ca2f71db83cb8fdcee6a371e6bad4
+DIST libppd-2.1.0.tar.xz 585288 BLAKE2B 87d325a659b98e2f489673fd2eb78daec83eafee990008380d852be17fbd990e4daa4a16bd5dc1e3a562040595b858c90d0747d815db0fb97fdccf97a3d4aa49 SHA512 06daf9149910298b2acd103c58f8bd345180219e42fab7dbc162b8370492e28b7bcecc6d72192fc8d053ec245a270d1901812662dd50687ff5b327a40ac0f475
DIST libppd-2.1b1.tar.xz 583692 BLAKE2B f9889ba7758097d2f794b16bdd74758223036daa8e49b191d07789e36ad7e2d69693c9ebb0b89c1c52f23f90fee8b56e1532246da90b1898caf1c557a416c20c SHA512 2b1ab3444f9de4a856f116aae83fd2aaa61adec9862bdd6dcff5fe2672e593b1e69e4da3638994ac4762dcc0e2640c5e3cbf3af247017d3790f01ef10395f54a
diff --git a/net-print/libppd/libppd-2.1.0.ebuild b/net-print/libppd/libppd-2.1.0.ebuild
new file mode 100644
index 000000000000..577c98a38e63
--- /dev/null
+++ b/net-print/libppd/libppd-2.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Legacy library for PPD files, split out of cups-filters"
+HOMEPAGE="https://github.com/OpenPrinting/libppd"
+SRC_URI="https://github.com/OpenPrinting/libppd/releases/download/${PV/_beta/b}/${P/_beta/b}.tar.xz"
+S="${WORKDIR}"/${P/_beta/b}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+postscript +poppler"
+
+# pdftops has various possible implementations, but the default
+# really needs to be decent
+REQUIRED_USE="|| ( postscript poppler )"
+
+RDEPEND="
+ >=net-print/cups-2
+ net-print/libcupsfilters
+ !<net-print/cups-filters-2.0.0
+ sys-libs/zlib
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ poppler? ( >=app-text/poppler-0.32[utils] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ # This does build time checks for (preferred) tool interfaces.
+ $(use_enable postscript ghostscript)
+ $(use_enable poppler pdftops)
+ # These fallbacks are just probed for the path. Always enable them.
+ --with-mutool-path="${EPREFIX}"/usr/bin/mutool
+ --with-pdftocairo-path="${EPREFIX}"/usr/bin/pdftocairo # from poppler
+ # unpackaged
+ --disable-acroread
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}