summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-30 21:05:28 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-11-01 22:55:05 +0100
commit0db2ec3d97452fece7e383d75014bfb71e279289 (patch)
tree7c470f9a2ea4f2bca6971ee2e516f12bed097e01 /net-vpn/iodine/iodine-0.7.0-r2.ebuild
parentnet-print/ink: drop 0.5.2 (diff)
downloadgentoo-0db2ec3d97452fece7e383d75014bfb71e279289.tar.gz
gentoo-0db2ec3d97452fece7e383d75014bfb71e279289.tar.bz2
gentoo-0db2ec3d97452fece7e383d75014bfb71e279289.zip
net-vpn/iodine: Port to EAPI 8
Closes: https://bugs.gentoo.org/819261 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-vpn/iodine/iodine-0.7.0-r2.ebuild')
-rw-r--r--net-vpn/iodine/iodine-0.7.0-r2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/net-vpn/iodine/iodine-0.7.0-r2.ebuild b/net-vpn/iodine/iodine-0.7.0-r2.ebuild
deleted file mode 100644
index 1309208900ab..000000000000
--- a/net-vpn/iodine/iodine-0.7.0-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit linux-info epatch toolchain-funcs
-
-DESCRIPTION="IP over DNS tunnel"
-HOMEPAGE="http://code.kryo.se/iodine/"
-SRC_URI="http://code.kryo.se/${PN}/${P}.tar.gz"
-
-CONFIG_CHECK="~TUN"
-
-LICENSE="ISC GPL-2" #GPL-2 for init script bug #426060
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-TestMessage.patch
- epatch "${FILESDIR}"/${P}-new-systemd.patch
-
- sed -e '/^\s@echo \(CC\|LD\)/d' \
- -e 's:^\(\s\)@:\1:' \
- -i {,src/}Makefile || die
-
- tc-export CC
-}
-
-src_compile() {
- #shipped ./Makefiles doesn't pass -j<n> to submake
- emake -C src TARGETOS=Linux all
-}
-
-src_install() {
- #don't re-run submake
- sed -e '/^install:/s: all: :' \
- -i Makefile || die
- emake prefix="${EPREFIX}"usr DESTDIR="${D}" install
-
- dodoc CHANGELOG README TODO
-
- newinitd "${FILESDIR}"/iodined-1.init iodined
- newconfd "${FILESDIR}"/iodined.conf iodined
- keepdir /var/empty
- fperms 600 /etc/conf.d/iodined
-}