summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2017-11-02 18:27:35 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2017-11-02 18:27:45 +0100
commitc06fba038a7fd27ef6bc684af127936bbd419b64 (patch)
treedf37afc24dbdde39c5527357f277819a54b76953 /net-vpn/wireguard
parentx11-libs/libXfont-1.5.3: sparc stable, bug 634044 (diff)
downloadgentoo-c06fba038a7fd27ef6bc684af127936bbd419b64.tar.gz
gentoo-c06fba038a7fd27ef6bc684af127936bbd419b64.tar.bz2
gentoo-c06fba038a7fd27ef6bc684af127936bbd419b64.zip
net-vpn/wireguard: fix compilation on LOCKDEP machines
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-vpn/wireguard')
-rw-r--r--net-vpn/wireguard/files/wireguard-0.0.20171101-funcfix.patch40
-rw-r--r--net-vpn/wireguard/wireguard-0.0.20171101.ebuild2
2 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/wireguard/files/wireguard-0.0.20171101-funcfix.patch b/net-vpn/wireguard/files/wireguard-0.0.20171101-funcfix.patch
new file mode 100644
index 000000000000..fe74e48b5dd4
--- /dev/null
+++ b/net-vpn/wireguard/files/wireguard-0.0.20171101-funcfix.patch
@@ -0,0 +1,40 @@
+From cc310a5dd1899417971e993d61d1230b14fe4f87 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 2 Nov 2017 16:07:26 +0100
+Subject: global: revert checkpatch.pl changes
+
+These changes were suggested by checkpatch.pl, but actually cause big
+problems depending on the options. Revert.
+---
+ src/noise.c | 2 +-
+ src/peer.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/noise.c b/src/noise.c
+index a0bea29..6ce9b78 100644
+--- a/src/noise.c
++++ b/src/noise.c
+@@ -118,7 +118,7 @@ void noise_keypair_put(struct noise_keypair *keypair)
+
+ struct noise_keypair *noise_keypair_get(struct noise_keypair *keypair)
+ {
+- RCU_LOCKDEP_WARN(!rcu_read_lock_bh_held(), "Calling " __func__ " without holding the RCU BH read lock");
++ RCU_LOCKDEP_WARN(!rcu_read_lock_bh_held(), "Taking noise keypair reference without holding the RCU BH read lock");
+ if (unlikely(!keypair || !kref_get_unless_zero(&keypair->refcount)))
+ return NULL;
+ return keypair;
+diff --git a/src/peer.c b/src/peer.c
+index 1580262..81b71d4 100644
+--- a/src/peer.c
++++ b/src/peer.c
+@@ -58,7 +58,7 @@ struct wireguard_peer *peer_create(struct wireguard_device *wg, const u8 public_
+
+ struct wireguard_peer *peer_get(struct wireguard_peer *peer)
+ {
+- RCU_LOCKDEP_WARN(!rcu_read_lock_bh_held(), "Calling " __func__ " without holding the RCU read lock");
++ RCU_LOCKDEP_WARN(!rcu_read_lock_bh_held(), "Taking peer reference without holding the RCU read lock");
+ if (unlikely(!peer || !kref_get_unless_zero(&peer->refcount)))
+ return NULL;
+ return peer;
+--
+cgit v1.1-33-gc3c0
diff --git a/net-vpn/wireguard/wireguard-0.0.20171101.ebuild b/net-vpn/wireguard/wireguard-0.0.20171101.ebuild
index fdc71975143a..579c9736f073 100644
--- a/net-vpn/wireguard/wireguard-0.0.20171101.ebuild
+++ b/net-vpn/wireguard/wireguard-0.0.20171101.ebuild
@@ -30,6 +30,8 @@ MODULE_NAMES="wireguard(kernel/drivers/net:src)"
BUILD_TARGETS="module"
CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_BLKCIPHER"
+PATCHES=( "${FILESDIR}/${P}-funcfix.patch" )
+
pkg_setup() {
if use module; then
linux-mod_pkg_setup