summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 22:25:05 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:08 -0400
commit72ae9bb6e2042f333f606e81cc57271dd19be540 (patch)
treeed3b87967c97cd05443686f137158adfe8000ccf /net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
parentnet-wireless/gnuradio: bump (diff)
downloadgentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.tar.gz
gentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.tar.bz2
gentoo-72ae9bb6e2042f333f606e81cc57271dd19be540.zip
net-wireless/gr-iqbal: bumps
prep for gr3.8 upgrade Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
new file mode 100644
index 000000000000..718058c00505
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.38.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8})
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
+else
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"