summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-21 19:11:04 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-21 20:22:57 +0200
commit7eb0d64c0327cd65f27c26639e440664b2c28aef (patch)
tree205dcd7551d8cf9c251a82218a4a033ac046f558 /net-wireless/madwimax/madwimax-0.1.1-r2.ebuild
parentnet-wireless/crackle: Remove 9999 ebuild (diff)
downloadgentoo-7eb0d64c0327cd65f27c26639e440664b2c28aef.tar.gz
gentoo-7eb0d64c0327cd65f27c26639e440664b2c28aef.tar.bz2
gentoo-7eb0d64c0327cd65f27c26639e440664b2c28aef.zip
net-wireless/madwimax: Port to EAPI 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-wireless/madwimax/madwimax-0.1.1-r2.ebuild')
-rw-r--r--net-wireless/madwimax/madwimax-0.1.1-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-wireless/madwimax/madwimax-0.1.1-r2.ebuild b/net-wireless/madwimax/madwimax-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..cfb08defa6d2
--- /dev/null
+++ b/net-wireless/madwimax/madwimax-0.1.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info udev
+
+DESCRIPTION="Reverse-engineered driver for WiMAX devices based on Samsung CMC-730 chip"
+HOMEPAGE="https://code.google.com/p/madwimax/"
+SRC_URI="https://madwimax.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/asciidoc
+ app-text/docbook2X
+ )"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ default
+ sed -i -e "s:\(for name in docbook2\)x-man:\1man\.pl:" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf="--without-man-pages"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" udevrulesdir="$(get_udevdir)"/rules.d install
+ mv "${ED}/$(get_udevdir)"/rules.d/{z60_,60-}madwimax.rules || die
+ dodoc README
+}