summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-29 14:52:45 +0000
committerSam James <sam@gentoo.org>2021-03-29 14:52:45 +0000
commit40465c4d6ed0a95ec4eb92ee87cff4dc922df23a (patch)
tree52c56d1a7a26e860a2bd63b5c6e4b5845d7cb54d /net-wireless
parentnet-wireless/iwd: change dev-python/docutils to a BDEPEND (diff)
downloadgentoo-40465c4d6ed0a95ec4eb92ee87cff4dc922df23a.tar.gz
gentoo-40465c4d6ed0a95ec4eb92ee87cff4dc922df23a.tar.bz2
gentoo-40465c4d6ed0a95ec4eb92ee87cff4dc922df23a.zip
net-wireless/iwd: sync live for EAPI 7 changes
Left out the non-EAPI 7 parts for maintainers to decide. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/iwd/iwd-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-wireless/iwd/iwd-9999.ebuild b/net-wireless/iwd/iwd-9999.ebuild
index c17d39b08802..3f5ab9303c14 100644
--- a/net-wireless/iwd/iwd-9999.ebuild
+++ b/net-wireless/iwd/iwd-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic linux-info systemd
#Set this variable to the required external ell version
@@ -24,15 +24,15 @@ SLOT="0"
IUSE="+client +crda +monitor ofono wired cpu_flags_x86_aes cpu_flags_x86_ssse3
standalone systemd"
-COMMON_DEPEND="
+DEPEND="
sys-apps/dbus
client? ( sys-libs/readline:0= )
"
-[[ -z "${ELL_REQ}" ]] || COMMON_DEPEND+=" ~dev-libs/ell-${ELL_REQ}"
+[[ -z "${ELL_REQ}" ]] || DEPEND+=" ~dev-libs/ell-${ELL_REQ}"
RDEPEND="
- ${COMMON_DEPEND}
+ ${DEPEND}
net-wireless/wireless-regdb
crda? ( net-wireless/crda )
standalone? (
@@ -41,12 +41,11 @@ RDEPEND="
)
"
-DEPEND="
- ${COMMON_DEPEND}
+BDEPEND="
virtual/pkgconfig
"
-[[ ${PV} == *9999* ]] && DEPEND+=" dev-python/docutils"
+[[ ${PV} == *9999* ]] && BDEPEND+=" dev-python/docutils"
pkg_setup() {
CONFIG_CHECK="