summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-01 13:17:50 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:45:46 -0400
commit7b47eb9ed50d1f16596069b4d45cdb9a7dfdb7b7 (patch)
treed857b3992b600347ff1b9ada28874ce8430e6b0e /net-wireless
parentnet-wireless/urh: fix deps (diff)
downloadgentoo-7b47eb9ed50d1f16596069b4d45cdb9a7dfdb7b7.tar.gz
gentoo-7b47eb9ed50d1f16596069b4d45cdb9a7dfdb7b7.tar.bz2
gentoo-7b47eb9ed50d1f16596069b4d45cdb9a7dfdb7b7.zip
net-wireless/gr-paint: update for gr3.8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-paint/Manifest1
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild52
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild12
3 files changed, 60 insertions, 5 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
index 97268d251644..347f504cf495 100644
--- a/net-wireless/gr-paint/Manifest
+++ b/net-wireless/gr-paint/Manifest
@@ -1 +1,2 @@
DIST gr-paint-0.0_p20200418.tar.gz 2129751 BLAKE2B 8767ff1ec791352dc701d0f7f68bbbd4088073379b4116ff2dbf2120b5e6e9b1a87ba0b0554a8489dc9b93cdb2ea5e3a8596b09482512fd1b10ea25d5b5c0fe9 SHA512 5f52e2baa090ed80d8a5b75846821b47163dcc055b94201fb59788bd85769a4e3f8c18654de45e68cb4088681b2db8b2327b5d14f176872bfe8bb2e01d7b6bfb
+DIST gr-paint-0.0_p20200517.tar.gz 1588114 BLAKE2B dffae6fdd6832ef7a39911b5f20d385e1691021e49659c36244c4aa1086fa74f4f59aceb4f208a24dd76854455183644c8f7db7e6ed0600664dc02f08e6682c5 SHA512 00b508b08baafd02e69197028a6408da81f5d1bf3dfe6d3229f248d60503ccec48f3fa0491bb785ed1ece40ea90d34544bc3b62e4506459488d56540b9d519c2
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild
new file mode 100644
index 000000000000..d1f2bf7295ec
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20200517.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint38.git"
+else
+ COMMIT="9cb4eabe3b570ccd1f53837681607d73501b5c1e"
+ SRC_URI="https://github.com/drmpeg/gr-paint38/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+#< drmpeg> What tests?
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ =net-wireless/gnuradio-3.8*:=[${PYTHON_SINGLE_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
index d8339979c4e2..d1f2bf7295ec 100644
--- a/net-wireless/gr-paint/gr-paint-9999.ebuild
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint38.git"
else
- COMMIT="e36b2c638061d14f1b3c3bf3e889a8c99c273930"
- SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ COMMIT="9cb4eabe3b570ccd1f53837681607d73501b5c1e"
+ SRC_URI="https://github.com/drmpeg/gr-paint38/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64"
fi
@@ -24,12 +24,14 @@ SLOT="0"
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+#< drmpeg> What tests?
+RESTRICT="test"
DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
- =net-wireless/gnuradio-3.7*:=[${PYTHON_SINGLE_USEDEP}]
+ =net-wireless/gnuradio-3.8*:=[${PYTHON_SINGLE_USEDEP}]
"
RDEPEND="${DEPEND}
media-gfx/imagemagick