summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-05 17:54:09 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-05 19:31:47 +0000
commit3d71b7bebff1fd73090f63498a5f0793526574be (patch)
treef77ff9904cab2d68a340e383c641cae75c5f8d1a /sci-astronomy/gnuastro/gnuastro-0.3.ebuild
parentnet-im/gajim: Remove vulnerable version (diff)
downloadgentoo-3d71b7bebff1fd73090f63498a5f0793526574be.tar.gz
gentoo-3d71b7bebff1fd73090f63498a5f0793526574be.tar.bz2
gentoo-3d71b7bebff1fd73090f63498a5f0793526574be.zip
sci-astronomy/gnuastro: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/gnuastro/gnuastro-0.3.ebuild')
-rw-r--r--sci-astronomy/gnuastro/gnuastro-0.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-astronomy/gnuastro/gnuastro-0.3.ebuild b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
new file mode 100644
index 000000000000..8cf56694b78f
--- /dev/null
+++ b/sci-astronomy/gnuastro/gnuastro-0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="GNU Astronomy Utilities"
+HOMEPAGE="https://www.gnu.org/software/gnuastro"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs threads"
+
+# jpeg, pdf, and libgit2 are forced deps
+# because they are automagically detected.
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ dev-libs/libgit2:=
+ sci-astronomy/wcslib:0=
+ sci-libs/cfitsio:0=
+ sci-libs/gsl:0=
+ virtual/jpeg:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-O3//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-bin-op-alltypes
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+ use doc && emake install-html
+}