summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/stiff/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/stiff/files')
-rw-r--r--sci-astronomy/stiff/files/stiff-configure.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-astronomy/stiff/files/stiff-configure.patch b/sci-astronomy/stiff/files/stiff-configure.patch
new file mode 100644
index 000000000000..15b8d9aa3010
--- /dev/null
+++ b/sci-astronomy/stiff/files/stiff-configure.patch
@@ -0,0 +1,63 @@
+--- configure.ac.orig 2009-03-10 12:34:36.000000000 +0000
++++ configure.ac 2009-07-28 17:26:22.000000000 +0100
+@@ -21,40 +21,14 @@
+
+ # Include macros
+ #sinclude(acx_pthread.m4)
+-sinclude(acx_prog_cc_optim.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS and LDFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+-# Checks for programs.
+-# GCC is chosen last because it is likely to yield less optimized code
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C
+ AM_PROG_CC_STDC
+ # C Compiler: Check that it is POSIX-compliant
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+@@ -107,19 +81,9 @@
+
+ # Link with gprof option
+ if test "$use_gprof" = "yes"; then
+- if test "$use_icc" = "yes"; then
+- CFLAGS="$CFLAGS -pq"
+- else
+- CFLAGS="$CFLAGS -pg"
+- fi
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+ # Override automatic CFLAGS and LDFLAGS with those of user
+ #if test -n "$mycflags"; then
+ #CFLAGS="$mycflags"