summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-26 01:06:31 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-26 01:06:31 +0200
commit60b0fd58e2765499b9d2a83c3293b7021b05908c (patch)
treeb066e2065141d300cd20344c08ab82ca30454272 /sci-biology/mosaik
parentsys-apps/systemd: QA_FLAGS_IGNORED for systemd-boot (diff)
downloadgentoo-60b0fd58e2765499b9d2a83c3293b7021b05908c.tar.gz
gentoo-60b0fd58e2765499b9d2a83c3293b7021b05908c.tar.bz2
gentoo-60b0fd58e2765499b9d2a83c3293b7021b05908c.zip
sci-biology/mosaik: Fix GCC 11 build
Closes: https://bugs.gentoo.org/788331 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/mosaik')
-rw-r--r--sci-biology/mosaik/files/mosaik-2.2.30-gcc11.patch60
-rw-r--r--sci-biology/mosaik/mosaik-2.2.30.ebuild8
2 files changed, 64 insertions, 4 deletions
diff --git a/sci-biology/mosaik/files/mosaik-2.2.30-gcc11.patch b/sci-biology/mosaik/files/mosaik-2.2.30-gcc11.patch
new file mode 100644
index 000000000000..918d882983a3
--- /dev/null
+++ b/sci-biology/mosaik/files/mosaik-2.2.30-gcc11.patch
@@ -0,0 +1,60 @@
+--- a/CommonSource/DataStructures/UnorderedMap.h
++++ b/CommonSource/DataStructures/UnorderedMap.h
+@@ -42,13 +42,9 @@
+
+ #else // all decent C++ compilers
+
+-#ifdef WIN32
+ #include <unordered_map>
+-#else // Linux
+-#include <tr1/unordered_map>
+-#endif
+
+-using namespace std::tr1;
++using namespace std;
+
+ #endif
+
+--- a/CommonSource/DataStructures/UnorderedSet.h
++++ b/CommonSource/DataStructures/UnorderedSet.h
+@@ -42,13 +42,9 @@
+
+ #else // all decent C++ compilers
+
+-#ifdef WIN32
+ #include <unordered_set>
+-#else // Linux
+-#include <tr1/unordered_set>
+-#endif
+
+-using namespace std::tr1;
++using namespace std;
+
+ #endif
+
+--- a/CommonSource/Utilities/RegexUtilities.h
++++ b/CommonSource/Utilities/RegexUtilities.h
+@@ -12,10 +12,7 @@
+ #define REGEXUTILITIES_H_
+
+ #include <iostream>
+-#ifdef WIN32
+ #include <regex>
+-using namespace std::tr1;
+-#endif
+ #include <string>
+ #include <vector>
+ #include <cstdlib>
+--- a/MosaikBuild/MosaikBuild.h
++++ b/MosaikBuild/MosaikBuild.h
+@@ -15,10 +15,7 @@
+ #include <iostream>
+ #include <fstream>
+ #include <map>
+-#ifdef WIN32
+ #include <regex>
+-using namespace std::tr1;
+-#endif
+ #include <set>
+ #include <sstream>
+ #include "ColorspaceUtilities.h"
diff --git a/sci-biology/mosaik/mosaik-2.2.30.ebuild b/sci-biology/mosaik/mosaik-2.2.30.ebuild
index 874edba4504d..633738b8f4c2 100644
--- a/sci-biology/mosaik/mosaik-2.2.30.ebuild
+++ b/sci-biology/mosaik/mosaik-2.2.30.ebuild
@@ -1,25 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs vcs-snapshot
DESCRIPTION="A reference-guided aligner for next-generation sequencing technologies"
HOMEPAGE="https://github.com/wanpinglee/MOSAIK"
SRC_URI="https://github.com/wanpinglee/MOSAIK/archive/5c25216d3522d6a33e53875cd76a6d65001e4e67.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/${P}/src"
-
PATCHES=(
"${FILESDIR}"/${P}-remove-platform-code.patch
"${FILESDIR}"/${P}-fix-build-system.patch
"${FILESDIR}"/${P}-Wformat-security.patch
"${FILESDIR}"/${P}-gcc7.patch
+ "${FILESDIR}"/${P}-gcc11.patch
)
src_configure() {