summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-08 22:35:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 23:16:40 +0100
commit38b011b475486566ee6ffc203fdc0c17b2cf577c (patch)
tree708f028e304c58a3c032760f00ac038b1f683db8 /sci-biology/piler/piler-1.0-r1.ebuild
parentsci-biology/pals: Modernise to EAPI 6 (diff)
downloadgentoo-38b011b475486566ee6ffc203fdc0c17b2cf577c.tar.gz
gentoo-38b011b475486566ee6ffc203fdc0c17b2cf577c.tar.bz2
gentoo-38b011b475486566ee6ffc203fdc0c17b2cf577c.zip
sci-biology/piler: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4165
Diffstat (limited to 'sci-biology/piler/piler-1.0-r1.ebuild')
-rw-r--r--sci-biology/piler/piler-1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/piler/piler-1.0-r1.ebuild b/sci-biology/piler/piler-1.0-r1.ebuild
new file mode 100644
index 000000000000..276ee9bc873e
--- /dev/null
+++ b/sci-biology/piler/piler-1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analysis of repetitive DNA found in genome sequences"
+HOMEPAGE="http://www.drive5.com/piler/"
+SRC_URI="http://www.drive5.com/piler/piler_source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ || (
+ sci-biology/muscle
+ sci-libs/libmuscle
+ )
+ sci-biology/pals"
+
+S=${WORKDIR}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.0-glibc-2.10.patch
+)
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ dobin piler
+}