summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/molden/molden-5.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/molden/molden-5.0.ebuild')
-rw-r--r--sci-chemistry/molden/molden-5.0.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/molden/molden-5.0.ebuild b/sci-chemistry/molden/molden-5.0.ebuild
new file mode 100644
index 000000000000..e4ad3b6d802d
--- /dev/null
+++ b/sci-chemistry/molden/molden-5.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 flag-o-matic toolchain-funcs
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac"
+HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
+SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MOLDEN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+RDEPEND="
+ x11-libs/libXmu
+ virtual/glu
+ opengl? (
+ media-libs/freeglut
+ virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ app-editors/vim"
+ # vim provides ex, which the build system uses (surf/Makefile, at least)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ambfor.patch \
+ "${FILESDIR}"/${P}-overflow.patch \
+ "${FILESDIR}"/${PN}-4.8-ldflags.patch \
+ "${FILESDIR}"/${PN}-4.7-implicit-dec.patch
+ sed \
+ -e 's:makedepend:gccmakedep:g' \
+ -e "s:/usr/include/sgidefs.h::g" \
+ -i surf/Makefile || die
+ sed 's:shell g77:shell $(FC):g' -i makefile || die
+}
+
+src_compile() {
+ # Use -mieee on alpha, according to the Makefile
+ use alpha && append-flags -mieee
+
+ # Honor CC, CFLAGS, FC, and FFLAGS from environment;
+ # unfortunately a bash bug prevents us from doing typeset and
+ # assignment on the same line.
+ typeset -a args
+ args=(
+ CC="$(tc-getCC) ${CFLAGS}" \
+ FC="$(tc-getFC)" \
+ LDR="$(tc-getFC)" \
+ FFLAGS="${FFLAGS}" )
+
+ einfo "Building Molden..."
+ emake -j1 "${args[@]}"
+ if use opengl ; then
+ einfo "Building Molden OpenGL helper..."
+ emake -j1 "${args[@]}" moldenogl
+ fi
+}
+
+src_install() {
+ dobin ${PN} g${PN}
+ if use opengl ; then
+ dobin ${PN}ogl
+ fi
+
+ dodoc HISTORY README REGISTER
+ cd doc
+ uncompress * && dodoc *
+}