summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/molequeue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/molequeue')
-rw-r--r--sci-chemistry/molequeue/Manifest1
-rw-r--r--sci-chemistry/molequeue/metadata.xml26
-rw-r--r--sci-chemistry/molequeue/molequeue-0.7.1.ebuild58
3 files changed, 85 insertions, 0 deletions
diff --git a/sci-chemistry/molequeue/Manifest b/sci-chemistry/molequeue/Manifest
new file mode 100644
index 000000000000..8511144b0f00
--- /dev/null
+++ b/sci-chemistry/molequeue/Manifest
@@ -0,0 +1 @@
+DIST molequeue-0.7.1.tar.gz 658745 SHA256 cdf184936a73e382b8cbff02768b9a04a3a64fec658d6dde4f6574236a73d3bf SHA512 09bdd45c1b2833be3a4f4cd3a0ade8d51276f8da150b0206d9c4a0d3b4999c58bc6cb3df48b9be70907d47c11bbd22aacc7c8d9ae401aa2f21a43405d6a8e3cd WHIRLPOOL 7ea17582495145b9d616bf1df58fbae3d4a6876c1490d5efdcefae1804cf7d29b08543a112ac7c033e2d2e18aa1537ed73a80f75484c90c7319f52dd469b5812
diff --git a/sci-chemistry/molequeue/metadata.xml b/sci-chemistry/molequeue/metadata.xml
new file mode 100644
index 000000000000..e7326743bc35
--- /dev/null
+++ b/sci-chemistry/molequeue/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+MoleQueue is an open-source, cross-platform, system-tray resident desktop
+application for abstracting, managing, and coordinating the execution of tasks
+both locally and on remote computational resources. It is built and tested and
+Linux, Mac OS X, and Windows, with nightly binaries currently available for
+Mac OS X and Windows. Users can set up local and remote queues that describe
+where the task will be executed. Each queue can have programs, with templates
+to facilitate the execution of the program. Input files can be staged, and
+output files collected using a standard interface.
+</longdescription>
+ <use>
+ <flag name="zeromq">Build with <pkg>net-libs/zeromq</pkg> support</flag>
+ <flag name="client">Build the client application</flag>
+ <flag name="server">Build the serve application</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">molequeue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/molequeue/molequeue-0.7.1.ebuild b/sci-chemistry/molequeue/molequeue-0.7.1.ebuild
new file mode 100644
index 000000000000..a7700f58577a
--- /dev/null
+++ b/sci-chemistry/molequeue/molequeue-0.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils multilib python-single-r1 versionator virtualx
+
+DESCRIPTION="Abstract, manage and coordinate execution of tasks"
+HOMEPAGE="http://www.openchemistry.org/OpenChemistry/project/molequeue.html"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+client doc server test +zeromq"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ server? ( client )
+ test? ( server )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ zeromq? ( net-libs/cppzmq:0= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTING)
+ $(cmake-utils_use_use zeromq ZERO_MQ)
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use client MoleQueue_BUILD_CLIENT)
+ $(cmake-utils_use server MoleQueue_BUILD_APPLICATION)
+ -DINSTALL_LIBRARY_DIR=$(get_libdir)
+ )
+ use zeromq && \
+ mycmakeargs+=( -DZeroMQ_ROOT_DIR=\"${EPREFIX}/usr\" )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile all $(usex doc documentation "")
+}
+
+src_test() {
+ VIRTUALX_COMMAND=cmake-utils_src_test
+ virtualmake
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ cmake-utils_src_install
+}