summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-14 12:53:50 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-14 12:56:06 +0100
commit78c04ff6ccc9d7a53282dc62da0317a4b5525e4d (patch)
tree764a6b06d7627a148ee955996cc7fcd325ac7599 /sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
parentsci-chemistry/aqua: QA fixes and EAPI bump (diff)
downloadgentoo-78c04ff6ccc9d7a53282dc62da0317a4b5525e4d.tar.gz
gentoo-78c04ff6ccc9d7a53282dc62da0317a4b5525e4d.tar.bz2
gentoo-78c04ff6ccc9d7a53282dc62da0317a4b5525e4d.zip
sci-chemistry/procheck: QA fixes and EAPI bump
* Bump to EAPI 6 * Generate missing checksums Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=614234 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/procheck/procheck-3.5.4-r3.ebuild')
-rw-r--r--sci-chemistry/procheck/procheck-3.5.4-r3.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild b/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
new file mode 100644
index 000000000000..585c9b591d9c
--- /dev/null
+++ b/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fortran-2 multilib toolchain-funcs versionator
+
+DESCRIPTION="Checks the stereochemical quality of a protein structure"
+HOMEPAGE="http://www.biochem.ucl.ac.uk/~roman/procheck/procheck.html"
+SRC_URI="
+ ${P}.tar.gz ${P}-README
+ doc? ( ${P}-manual.tar.gz )"
+
+LICENSE="procheck"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="app-shells/tcsh"
+DEPEND="${RDEPEND}"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ elog "Please visit http://www.ebi.ac.uk/thornton-srv/software/PROCHECK/download.html"
+ elog "And follow the instruction for downloading."
+ elog "Files should be stored in following way"
+ elog "${PN}.tar.gz -> ${DISTDIR}/${P}.tar.gz"
+ elog "README -> ${DISTDIR}/${P}-README"
+ use doc && elog "manual.tar.gz -> ${DISTDIR}/${P}-manual.tar.gz"
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-close.patch
+)
+
+src_compile() {
+ emake \
+ F77=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ COPTS="${CFLAGS}" \
+ FOPTS="${FFLAGS} -std=legacy"
+}
+
+src_install() {
+ for i in *.scr; do
+ newbin ${i} ${i%.scr}
+ done
+
+ exeinto /usr/libexec/${PN}/
+ doexe \
+ anglen \
+ clean \
+ rmsdev \
+ secstr \
+ gfac2pdb \
+ pplot \
+ bplot \
+ tplot \
+ mplot \
+ vplot \
+ viol2pdb \
+ wirplot \
+ nb
+ dodoc "${DISTDIR}"/${P}-README
+
+ insinto /usr/libexec/${PN}/
+ doins *.dat *.prm
+ newins resdefs.dat resdefs.data
+
+ cat >> "${T}"/30${PN} <<- EOF
+ prodir="${EPREFIX}/usr/libexec/${PN}/"
+ EOF
+
+ doenvd "${T}"/30${PN}
+
+ if use doc; then
+ pushd "${WORKDIR}" > /dev/null
+ docinto html
+ dodoc -r manual
+ popd > /dev/null
+ fi
+}