summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/surf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/surf')
-rw-r--r--sci-chemistry/surf/Manifest1
-rw-r--r--sci-chemistry/surf/metadata.xml5
-rw-r--r--sci-chemistry/surf/surf-1.0.ebuild44
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/surf/Manifest b/sci-chemistry/surf/Manifest
new file mode 100644
index 000000000000..7e50ca58e561
--- /dev/null
+++ b/sci-chemistry/surf/Manifest
@@ -0,0 +1 @@
+DIST surf-1.0.tar.Z 74347 SHA256 6d032e4b749e5e1971b5d97b0fcf552029068a87bcaebd6ce92db27179f7cb0a
diff --git a/sci-chemistry/surf/metadata.xml b/sci-chemistry/surf/metadata.xml
new file mode 100644
index 000000000000..9ac9ffdb3a41
--- /dev/null
+++ b/sci-chemistry/surf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/surf/surf-1.0.ebuild b/sci-chemistry/surf/surf-1.0.ebuild
new file mode 100644
index 000000000000..eadfa758a755
--- /dev/null
+++ b/sci-chemistry/surf/surf-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Solvent accesible Surface calculator"
+HOMEPAGE="http://www.ks.uiuc.edu/"
+SRC_URI="http://www.ks.uiuc.edu/Research/vmd/extsrcs/surf.tar.Z -> ${P}.tar.Z"
+
+LICENSE="SURF"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="
+ !www-client/surf
+ sys-apps/ed
+ x11-misc/makedepend"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ sed \
+ -e 's:$(CC) $(CFLAGS) $(OBJS):$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS):g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake depend \
+ && emake \
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS} \$(INCLUDE)" \
+ CFLAGS="${CFLAGS} \$(INCLUDE)" \
+ || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README || die
+}