summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:15:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:15:41 +0200
commitf0966300dbbfea0b0e339982738d958bafb252dc (patch)
tree4e49380c01621579fbf3df8c5df1b935978e3e92 /sci-geosciences/folium/folium-0.12.1.ebuild
parentsci-libs/branca: Add to tree (diff)
downloadgentoo-f0966300dbbfea0b0e339982738d958bafb252dc.tar.gz
gentoo-f0966300dbbfea0b0e339982738d958bafb252dc.tar.bz2
gentoo-f0966300dbbfea0b0e339982738d958bafb252dc.zip
sci-geosciences/folium: add to tree
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences/folium/folium-0.12.1.ebuild')
-rw-r--r--sci-geosciences/folium/folium-0.12.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/folium/folium-0.12.1.ebuild b/sci-geosciences/folium/folium-0.12.1.ebuild
new file mode 100644
index 000000000000..ef7a70a505ac
--- /dev/null
+++ b/sci-geosciences/folium/folium-0.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python Data, Leaflet.js Maps"
+HOMEPAGE="https://github.com/python-visualization/folium"
+SRC_URI="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-scm.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+RDEPEND="sci-libs/branca[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r tests/selenium || die
+ default
+}