summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-15 01:40:23 +0000
committerSam James <sam@gentoo.org>2023-01-15 01:41:08 +0000
commit73b07b4309f865a043ccbab7cb0e9c4b361b9d4c (patch)
treef59df07b4ed5fb986d6f99d9d25499fa7396e678 /sci-geosciences/gpsd
parentsys-devel/gdb: cleanup confusing test comment (diff)
downloadgentoo-73b07b4309f865a043ccbab7cb0e9c4b361b9d4c.tar.gz
gentoo-73b07b4309f865a043ccbab7cb0e9c4b361b9d4c.tar.bz2
gentoo-73b07b4309f865a043ccbab7cb0e9c4b361b9d4c.zip
sci-geosciences/gpsd: add 3.25
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/Manifest1
-rw-r--r--sci-geosciences/gpsd/gpsd-3.25.ebuild229
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild18
3 files changed, 240 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/Manifest b/sci-geosciences/gpsd/Manifest
index 19ecf289fc4f..2aa15502e89e 100644
--- a/sci-geosciences/gpsd/Manifest
+++ b/sci-geosciences/gpsd/Manifest
@@ -1,2 +1,3 @@
DIST gpsd-3.23.1.tar.xz 3450632 BLAKE2B 5057d2ee4734be169c909fd4b8fbe9b5bd65c99ab3ee7e5cc843ffc3e3a033f29f7a677e7dc0a09bbfba28a9a95336e43e4dda09455d90c7ad5a548848778cbc SHA512 21a14e1d8dfa7bef08560107c333c5ad8381914c68ff47ce091506733623a3e5c1dc79e1af303105aeec96490e17d2f10ba0a359250a58f9101af157baa5479d
DIST gpsd-3.24.tar.xz 3596040 BLAKE2B 999963258aae883df4ae84b8011324971c25ebc84a04b169b1984bf61ecce6b20e4fdf112ff23c54d7647bcec374eeb285f377833cb303dad3449e4b3a028f07 SHA512 96b1967220ff8837271a8974883081a8254fc3b7f3ab3a111ef49ccfa88d86bc82081cf24d33ef849fb5867d6263bb4ec798972e15095501e1feafdc4c14777d
+DIST gpsd-3.25.tar.xz 3647488 BLAKE2B 0c6f4eff5d2489e88ef0a35b9c089e30805368d491603e644a917a189c95316750913ec1d393a5a2ae7ebaf9279a4d1f19907333c35652178304c69102262849 SHA512 efc26221deb08ef8f34aed7d56809c1056320700f55d08519f1b44fd0c3c8ffc49672980301970fc096d88a0022d7cf207d329356dd81ca3618b7bedc3b078d6
diff --git a/sci-geosciences/gpsd/gpsd-3.25.ebuild b/sci-geosciences/gpsd/gpsd-3.25.ebuild
new file mode 100644
index 000000000000..53bc8d53f9fd
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.25.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{9..11} )
+SCONS_MIN_VERSION="2.3.0"
+
+inherit distutils-r1 scons-utils systemd toolchain-funcs udev
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping clients"
+HOMEPAGE="https://gpsd.gitlab.io/gpsd/"
+
+LICENSE="BSD"
+SLOT="0/30"
+
+GPSD_PROTOCOLS=(
+ aivdm ashtech earthmate evermore fury fv18 garmin garmintxt geostar
+ gpsclock greis isync itrax navcom nmea2000 oceanserver oncore
+ rtcm104v2 rtcm104v3 sirf skytraq superstar2 tnt tripmate tsip ublox
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp +python qt5 +shm +sockets static systemd test udev usb X"
+REQUIRED_USE="
+ X? ( python )
+ gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
+ gpsd_protocols_isync? ( gpsd_protocols_ublox )
+ gpsd_protocols_ublox? ( python )
+ gpsd_protocols_greis? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ qt5? ( cxx )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/gpsd
+ acct-group/dialout
+ >=net-misc/pps-tools-0.0.20120407
+ bluetooth? ( net-wireless/bluez:= )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ncurses? ( sys-libs/ncurses:= )
+ ntp? ( || (
+ net-misc/ntp
+ net-misc/ntpsec
+ net-misc/chrony
+ ) )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ )
+ python? ( ${PYTHON_DEPS} )
+ gpsd_protocols_ublox? ( dev-python/pyserial )
+ gpsd_protocols_greis? ( dev-python/pyserial )
+ usb? ( virtual/libusb:1 )
+ X? ( dev-python/pygobject:3[cairo,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ $(python_gen_any_dep 'dev-util/scons[${PYTHON_USEDEP}]')
+ test? ( sys-devel/bc )"
+
+# asciidoctor package is for man page generation
+if [[ ${PV} == *9999* ]] ; then
+ BDEPEND+=" dev-ruby/asciidoctor"
+fi
+
+python_check_deps() {
+ has_version -b "dev-util/scons[${PYTHON_USEDEP}]" || return 1
+}
+
+src_prepare() {
+ # Make sure our list matches the source.
+ local src_protocols=$(echo $(
+ sed -n '/# GPS protocols/,/# Time service/{s:#.*::;s:[(",]::g;p}' "${S}"/SConscript | awk '{print $1}' | LC_ALL=C sort
+ ) )
+
+ if [[ ${src_protocols} != ${GPSD_PROTOCOLS[*]} ]] ; then
+ eerror "Detected protocols: ${src_protocols}"
+ eerror "Ebuild protocols: ${GPSD_PROTOCOLS[*]}"
+ die "please sync ebuild & source"
+ fi
+
+ # bug #807661
+ sed -i -e 's:$SRCDIR/gpsd.hotplug:$SRCDIR/../gpsd.hotplug:' SConscript || die
+
+ default
+
+ use python && distutils-r1_src_prepare
+}
+
+python_prepare_all() {
+ python_setup
+
+ # bug #796476
+ python_export_utf8_locale
+
+ # Extract python info out of SConscript so we can use saner distribute
+ pyarray() { sed -n "/^ *$1 *= *\\[/,/\\]/p" SConscript ; }
+ local pyprogs=$(pyarray python_progs)
+ local pybins=$("${PYTHON}" -c "${pyprogs}; \
+ print(list(set(python_progs) - {'xgps', 'xgpsspeed', 'ubxtool', 'zerk'}))" || die "Unable to list pybins")
+ # Handle conditional tools manually. #666734
+ use X && pybins+="+ ['xgps', 'xgpsspeed']"
+ use gpsd_protocols_ublox && pybins+="+ ['ubxtool']"
+ use gpsd_protocols_greis && pybins+="+ ['zerk']"
+ local pysrcs=$(pyarray packet_ffi_extension)
+ local packet=$("${PYTHON}" -c "${pysrcs}; print(packet_ffi_extension)" || die "Unable to extract packet types")
+
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConscript ; }
+ pyvar2() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+
+ # Post 3.19 the clienthelpers were merged into gps.packet
+
+ # TODO: Fix hardcoding https://gpsd.io/ for now for @URL@
+ sed \
+ -e "s|@VERSION@|$(pyvar2 gpsd_version | sed -e 's:\"::g')|" \
+ -e "s|@URL@|https://gpsd.io/|" \
+ -e "s|@DEVMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@DOWNLOAD@|$(pyvar download)|" \
+ -e "s|@IRCCHAN@|$(pyvar ircchan)|" \
+ -e "s|@ISSUES@|$(pyvar bugtracker)|" \
+ -e "s|@MAILMAN@|$(pyvar mailman)|" \
+ -e "s|@PROJECTPAGE@|$(pyvar projectpage)|" \
+ -e "s|@SUPPORT@|https://gpsd.io/SUPPORT.html|" \
+ -e "s|@WEBSITE@|https://gpsd.io/|" \
+ "${S}"/packaging/gpsd-setup.py.in > setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ scons_opts=(
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
+ udevdir="$(get_udevdir)"
+ rundir="/run"
+ chrpath=False
+ gpsd_user=gpsd
+ gpsd_group=dialout
+ nostrip=True
+ systemd=$(usex systemd)
+ unitdir="$(systemd_get_systemunitdir)"
+ shared=$(usex !static True False)
+ bluez=$(usex bluetooth)
+ libgpsmm=$(usex cxx)
+ clientdebug=$(usex debug)
+ dbus_export=$(usex dbus)
+ ipv6=$(usex ipv6)
+ timing=$(usex latency-timing)
+ ncurses=$(usex ncurses)
+ ntpshm=$(usex ntp)
+ pps=$(usex ntp)
+ python=$(usex python)
+ # force a predictable python libdir because lib vs. lib64 usage differs
+ # from 3.5 to 3.6+
+ $(usex python python_libdir="${EPREFIX}"/python-discard "")
+ qt=$(usex qt5)
+ shm_export=$(usex shm)
+ socket_export=$(usex sockets)
+ usb=$(usex usb)
+ )
+
+ if [[ ${PV} != *9999* ]] ; then
+ scons_opts+=( manbuild=False )
+ fi
+
+ use X && scons_opts+=( xgps=1 xgpsspeed=1 )
+ use qt5 && scons_opts+=( qt_versioned=5 )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ scons_opts+=( ${protocol}=$(usex gpsd_protocols_${protocol}) )
+ done
+
+ # bug #809260
+ python_setup
+}
+
+src_compile() {
+ export CHRPATH=
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons "${scons_opts[@]}"
+
+ pushd "${P}" || die
+ ln -sf ../setup.py . || die
+ use python && distutils-r1_src_compile
+ popd || die
+}
+
+src_test() {
+ escons "${scons_opts[@]}" check
+}
+
+python_test() {
+ # Silence QA check which gets confused by layout(?). We do run the tests.
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" escons install "${scons_opts[@]}" $(usev udev udev-install)
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ # Cleanup bad alt copy due to Scons
+ rm -rf "${D}"/python-discard/gps*
+ find "${D}"/python-discard/ -type d -delete
+ # Install correct multi-python copy
+ pushd "${P}" || die
+ use python && distutils-r1_src_install
+ popd || die
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+}
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 9bf817942858..53bc8d53f9fd 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
SCONS_MIN_VERSION="2.3.0"
inherit distutils-r1 scons-utils systemd toolchain-funcs udev
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
inherit git-r3
else
@@ -21,7 +21,7 @@ DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping c
HOMEPAGE="https://gpsd.gitlab.io/gpsd/"
LICENSE="BSD"
-SLOT="0/29"
+SLOT="0/30"
GPSD_PROTOCOLS=(
aivdm ashtech earthmate evermore fury fv18 garmin garmintxt geostar
@@ -30,13 +30,15 @@ GPSD_PROTOCOLS=(
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp +python qt5 +shm +sockets static systemd test udev usb X"
-REQUIRED_USE="X? ( python )
+REQUIRED_USE="
+ X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
gpsd_protocols_isync? ( gpsd_protocols_ublox )
gpsd_protocols_ublox? ( python )
gpsd_protocols_greis? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
- qt5? ( cxx )"
+ qt5? ( cxx )
+"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -208,13 +210,13 @@ python_test() {
}
src_install() {
- DESTDIR="${D}" escons install "${scons_opts[@]}" $(usex udev udev-install '')
+ DESTDIR="${D}" escons install "${scons_opts[@]}" $(usev udev udev-install)
newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
newinitd "${FILESDIR}"/gpsd.init-2 gpsd
# Cleanup bad alt copy due to Scons
- rm -rf "${D}"/python-discard/gps*
+ rm -rf "${D}"/python-discard/gps*
find "${D}"/python-discard/ -type d -delete
# Install correct multi-python copy
pushd "${P}" || die