summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Zigo <tomas.zigo@slovanet.sk>2022-01-13 10:12:23 +0100
committerSam James <sam@gentoo.org>2022-01-16 01:46:17 +0000
commit07f7fc6cffd2f50c1b375efbcb97dcfea04cf427 (patch)
tree85ce3f221133dbef115a19951eddf0faa25013c0 /sci-geosciences
parentsci-geosciences/grass: bump dev version to 8.1 (diff)
downloadgentoo-07f7fc6cffd2f50c1b375efbcb97dcfea04cf427.tar.gz
gentoo-07f7fc6cffd2f50c1b375efbcb97dcfea04cf427.tar.bz2
gentoo-07f7fc6cffd2f50c1b375efbcb97dcfea04cf427.zip
sci-geosciences/grass: add GVERSION global var
Signed-off-by: Tomas Zigo <tomas.zigo@slovanet.sk> Closes: https://github.com/gentoo/gentoo/pull/23769 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index b7c94db005af..d0b73c80b283 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -9,15 +9,15 @@ WX_GTK_VER="3.0-gtk3"
inherit autotools desktop git-r3 python-single-r1 toolchain-funcs wxwidgets xdg
-MY_P="${PN}8.1"
-MY_PM="${MY_P/.}"
-
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
LICENSE="GPL-2"
SLOT="0/8.1"
+GVERSION=${SLOT#*/}
+MY_P="${PN}${GVERSION}"
+MY_PM="${MY_P/.}"
IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -234,9 +234,9 @@ GISBASE = os.path.normpath(\"${gisbase}\"):" \
os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
-i "${ED}"/usr/bin/grass || die
- # set proper GISDBASE directory path in the demolocation .grassrc80 file
+ # set proper GISDBASE directory path in the demolocation .grassrc${GVERSION//.} file
sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
- -i "${ED}"${gisbase}/demolocation/.grassrc81 || die
+ -i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
if use X; then
local GUI="-gui"