summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:30:00 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:31:20 +0200
commit0be531f69a84588ff8712fb80bee2654a6061654 (patch)
treea2631860d2dbdd4ae5db303bf7afffb99f07814a /sci-libs/kissfft/kissfft-9999.ebuild
parentsci-misc/vitables: update EAPI 7 -> 8, PEP517, enable py3_10 (diff)
downloadgentoo-0be531f69a84588ff8712fb80bee2654a6061654.tar.gz
gentoo-0be531f69a84588ff8712fb80bee2654a6061654.tar.bz2
gentoo-0be531f69a84588ff8712fb80bee2654a6061654.zip
sci-libs/kissfft: enable py3.10, py3.11 and disable py3.7
Closes: https://bugs.gentoo.org/846266 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/kissfft/kissfft-9999.ebuild')
-rw-r--r--sci-libs/kissfft/kissfft-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/kissfft/kissfft-9999.ebuild b/sci-libs/kissfft/kissfft-9999.ebuild
index bc06fee4c8e0..814cce24e11a 100644
--- a/sci-libs/kissfft/kissfft-9999.ebuild
+++ b/sci-libs/kissfft/kissfft-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake python-any-r1 toolchain-funcs
@@ -33,7 +33,7 @@ DEPEND="
"
python_check_deps() {
- has_version -d "dev-python/numpy[${PYTHON_USEDEP}]"
+ python_has_version -d "dev-python/numpy[${PYTHON_USEDEP}]"
}
pkg_pretend() {