summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-02-28 21:47:56 +1300
committerMichael Orlitzky <mjo@gentoo.org>2021-02-28 09:37:31 -0500
commite7004a2ce7d79800b2eb8c0e80fb1c4b27ebd928 (patch)
treea2aa6f2adf32edc53bd2d7999001e90c954d6478 /sci-libs/libbraiding/libbraiding-1.1.ebuild
parentsci-mathematics/rw: new upstream version (diff)
downloadgentoo-e7004a2ce7d79800b2eb8c0e80fb1c4b27ebd928.tar.gz
gentoo-e7004a2ce7d79800b2eb8c0e80fb1c4b27ebd928.tar.bz2
gentoo-e7004a2ce7d79800b2eb8c0e80fb1c4b27ebd928.zip
sci-libs/libbraiding: New upstream release
Closes: https://github.com/gentoo/gentoo/pull/19707 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/libbraiding/libbraiding-1.1.ebuild')
-rw-r--r--sci-libs/libbraiding/libbraiding-1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/libbraiding/libbraiding-1.1.ebuild b/sci-libs/libbraiding/libbraiding-1.1.ebuild
new file mode 100644
index 000000000000..890bf6aaa4cd
--- /dev/null
+++ b/sci-libs/libbraiding/libbraiding-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Expose the functionality of cbraid as a shared library"
+HOMEPAGE="https://github.com/miguelmarco/libbraiding"
+
+SRC_URI="https://github.com/miguelmarco/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+# A few source headers still say GPLv2, but I believe that to be an
+# oversight: https://github.com/jeanluct/cbraid/issues/4
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}