summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-08-12 19:51:43 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-08-12 19:55:03 -0500
commitd49fd1e7ec725617499640d9388139251c1c5e1c (patch)
treecaa9401a90008484a8c85d653ce6e370eb62f177 /sci-libs/libsc
parentmedia-libs/mesa: Version bump to 17.2.0_rc4 (diff)
downloadgentoo-d49fd1e7ec725617499640d9388139251c1c5e1c.tar.gz
gentoo-d49fd1e7ec725617499640d9388139251c1c5e1c.tar.bz2
gentoo-d49fd1e7ec725617499640d9388139251c1c5e1c.zip
sci-libs/libsc: version bump to 2.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-libs/libsc')
-rw-r--r--sci-libs/libsc/Manifest1
-rw-r--r--sci-libs/libsc/libsc-2.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sci-libs/libsc/Manifest b/sci-libs/libsc/Manifest
index 475f0dc527be..5fddc5460dc4 100644
--- a/sci-libs/libsc/Manifest
+++ b/sci-libs/libsc/Manifest
@@ -1,2 +1,3 @@
DIST libsc-1.0.tar.gz 257930 SHA256 a9f8a0f342a4a92c4031735e044e7ee73d9fd7e6df3e50a51c4c5016e27ed1ba SHA512 bf5af600e9cbd4038b1bd40c88776b21be5d474e34f9aacf287b890d262a22dc50ca27982c2eb9adba9735c8d9bb1fc31de2a27b24cdab534e3b2f610d76db7d WHIRLPOOL 56f89fcaf90bc8d4f872cee4fe150f692933b39376758c42b67d2e42659c19a9332a1d5e6d2d81c011dade0c6ab40c526c69ce2168fe41060f5d4be1a6595b1b
DIST libsc-1.1.tar.gz 263643 SHA256 99c3fb3b7d6514ccaa667bdc848a7308c00f05bf6fdc0561ce286db9644ee03e SHA512 a3d8bea406a1987e68e88dd587aebe28c796f2a5bddfc381b34b5eb1448e0ac23889cc6f97fc1e4010289f83996180db42cbb001d0518360349b993dd37d4579 WHIRLPOOL b6c123cd245e4beb4cd6479e9d781d86784fab6975edc20562c14b5ecc59dbc824aca10fb02e4fa7612f0b2743fd7c7d3799f203546c5859896812a21e1362df
+DIST libsc-2.0.tar.gz 296392 SHA256 759c7ed33537fc5eb2fee4c9d90f5d80f7112f13042f4d2d5f34d6c6461cb8e6 SHA512 e4cfe42a1c1fe17412e1ffb6ebebe1f760861a7fb707a6f8fd01cdebda96b166ee05e7ff034f3b9e30de5e9baa82c9a2cebe93d40772dbd206603321de40559c WHIRLPOOL 247a985d948ceba0e682491f4b85d761c76599a82d5f3096ba5214d64691bff1b497739d1f2687ac6a6b04c121eb057c3770a17ee7d5040af16a288bb9f79299
diff --git a/sci-libs/libsc/libsc-2.0.ebuild b/sci-libs/libsc/libsc-2.0.ebuild
new file mode 100644
index 000000000000..229d1ccd05fc
--- /dev/null
+++ b/sci-libs/libsc/libsc-2.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils
+
+DESCRIPTION="Support for parallel scientific applications"
+HOMEPAGE="http://www.p4est.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cburstedde/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/cburstedde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="debug examples mpi openmp romio static-libs threads"
+
+REQUIRED_USE="romio? ( mpi )"
+
+RDEPEND="
+ dev-lang/lua:*
+ sys-apps/util-linux
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[romio?] )"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+AUTOTOOLS_AUTORECONF=true
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use openmp; then
+ tc-has-openmp || \
+ die "Please select an openmp capable compiler like gcc[openmp]"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Inject a version number into the build system
+ echo "${PV}" > ${S}/.tarball-version
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable mpi)
+ $(use_enable openmp openmp)
+ $(use_enable romio mpiio)
+ $(use_enable static-libs static)
+ $(use_enable threads pthread)
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/*
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ # Remove compiled example binaries in case of -examples:
+ rm -r "${ED}"/usr/bin || die "rm failed"
+ fi
+
+ # Remove ac files, bug #619806
+ rm -r "${ED}"/usr/share/aclocal || die "rm failed"
+
+ # Fix wrong installation paths:
+ dodir /usr/share/libsc
+ mv "${ED}"/etc/* "${ED}"/usr/share/libsc || die "mv failed"
+ rmdir "${ED}"/etc/ || die "rmdir failed"
+ mv "${ED}"/usr/share/ini/* "${ED}"/usr/share/libsc || die "mv failed"
+ rmdir "${ED}"/usr/share/ini || die "rmdir failed"
+}