summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 07:55:32 +0100
committerSam James <sam@gentoo.org>2022-05-15 01:00:17 +0000
commitdb4763228facce4f5b03a13a4c68e7cbdb3b9b98 (patch)
tree1186e9bea413b268135b5f0928c3f93ec1387575 /sci-libs/rocSPARSE
parentnet-nds/openldap: egrep -> grep -E (diff)
downloadgentoo-db4763228facce4f5b03a13a4c68e7cbdb3b9b98.tar.gz
gentoo-db4763228facce4f5b03a13a4c68e7cbdb3b9b98.tar.bz2
gentoo-db4763228facce4f5b03a13a4c68e7cbdb3b9b98.zip
sci-libs/rocSPARSE: egrep -> grep -E
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/rocSPARSE')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild2
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild
index f32d34643e14..e9c16ef9287c 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r3.ebuild
@@ -88,7 +88,7 @@ src_prepare() {
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"
diff --git a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
index 4203ba70e4de..b97857618b6c 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-5.0.2.ebuild
@@ -89,7 +89,7 @@ src_prepare() {
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"