summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-06 12:12:03 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-06 12:12:20 +0100
commitb6e14c5cfc63a44e8bd04f36ae0be49436d6f299 (patch)
treedd74f1a7d72a076d3996d7fe641b42ae7ac2d1ce /sci-libs/scikit-image
parentdev-python/lazy_loader: new package, add 0.3 (diff)
downloadgentoo-b6e14c5cfc63a44e8bd04f36ae0be49436d6f299.tar.gz
gentoo-b6e14c5cfc63a44e8bd04f36ae0be49436d6f299.tar.bz2
gentoo-b6e14c5cfc63a44e8bd04f36ae0be49436d6f299.zip
sci-libs/scikit-image: add 0.22.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/scikit-image')
-rw-r--r--sci-libs/scikit-image/Manifest1
-rw-r--r--sci-libs/scikit-image/scikit-image-0.22.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/scikit-image/Manifest b/sci-libs/scikit-image/Manifest
index 66003042df98..8b42da1c8888 100644
--- a/sci-libs/scikit-image/Manifest
+++ b/sci-libs/scikit-image/Manifest
@@ -1 +1,2 @@
DIST scikit-image-0.19.3.tar.gz 22232287 BLAKE2B 855584be0e69ac6e0dc7a17a68a1bca6843b471073e63d098b4933bc301eab5246d4cd2b444960de7fcd37012b66f7ba8cd6030ac485a7ab3aa1d36501aef0c7 SHA512 cda1699200e19155da13e313eb129771b7bb895913e552b959a3374267fe4f73c33d5e6e2fa2d49326903c901925797e46b9f05342a78c5332df1c266d37471a
+DIST scikit_image-0.22.0.tar.gz 22685018 BLAKE2B 7d0a65f75f5a58211e21501d6cc6a638f1d36e9a2198a3ad9ff2f230890496c41d5e6cdaed02bbaa62f26aa57fd24fc993656cbdfc2c9c9750147d0f325e56f1 SHA512 4b8c097cd5465f57b1c0879363fe3bdc0941decf2d1f8a881f13f2b7f3207c425f3a0cdcb4be0eed7b33d3ac2f3f8b1835d1cfa69cd3fa2ff5e0be11385fef48
diff --git a/sci-libs/scikit-image/scikit-image-0.22.0.ebuild b/sci-libs/scikit-image/scikit-image-0.22.0.ebuild
new file mode 100644
index 000000000000..2be8ab470ef9
--- /dev/null
+++ b/sci-libs/scikit-image/scikit-image-0.22.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=meson-python
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Image processing routines for SciPy"
+HOMEPAGE="
+ https://scikit-image.org/
+ https://github.com/scikit-image/scikit-image/
+ https://pypi.org/project/scikit-image/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/imageio-2.27[${PYTHON_USEDEP}]
+ >=dev-python/lazy_loader-0.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.8[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.8[sparse(+),${PYTHON_USEDEP}]
+ >=dev-python/tifffile-2022.8.12[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+DOCS=( CONTRIBUTORS.txt RELEASE.txt )
+
+distutils_enable_tests pytest
+# There is a programmable error in your configuration file:
+#distutils_enable_sphinx doc/source dev-python/numpydoc dev-python/myst-parser
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${PN//-/_}-${PV}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/skimage" || die
+ distutils-r1_python_test
+}
+
+pkg_postinst() {
+ optfeature "FITS io capability" dev-python/astropy
+ optfeature "GTK" dev-python/pygtk
+ optfeature "Parallel computation" dev-python/dask
+ optfeature "io plugin providing most standard formats" dev-python/imread
+ optfeature "plotting" dev-python/matplotlib
+ optfeature "wavelet transformations" dev-python/pywavelets
+ optfeature "io plugin providing a wide variety of formats, including specialized formats using in medical imaging." dev-python/simpleitk
+}