summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-09-02 12:36:40 -0400
committerRick Farina <zerochaos@gentoo.org>2022-09-02 12:36:45 -0400
commite37308a9795570c15334f65eef34a22d0fae2202 (patch)
tree5b837379225db294d1a7787f7ac103812b8a1f56 /sci-libs/volk
parentsci-libs/volk: drop 2.4.1 (diff)
downloadgentoo-e37308a9795570c15334f65eef34a22d0fae2202.tar.gz
gentoo-e37308a9795570c15334f65eef34a22d0fae2202.tar.bz2
gentoo-e37308a9795570c15334f65eef34a22d0fae2202.zip
sci-libs/volk: add 2.5.1
Signed-off-by: Rick Farina <zerochaos@gentoo.org> Remove stray pyc/pyo files Closes: https://bugs.gentoo.org/862990
Diffstat (limited to 'sci-libs/volk')
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/volk-2.5.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
index 60292a150ed8..4659d3b9cd25 100644
--- a/sci-libs/volk/Manifest
+++ b/sci-libs/volk/Manifest
@@ -1 +1,2 @@
DIST volk-2.5.0.tar.xz 322280 BLAKE2B edbf0f7ffecf08e8f0d8ebbb85a9bc943286c5d022442d0d7e480be4ecbd696a8b2e87e4d16d7133467b429e4894a1d166c534b5a05630cb313906aed8476cfe SHA512 94e5af925d6b6e157445ca80c2ba47a92f5ee681716d2a70a5519caa30a603b3f31a9f1ccbd14ef65349645b56a3f406b4aa1f354c322be60bd76d646a4850c6
+DIST volk-2.5.1.tar.xz 362792 BLAKE2B dfaaddb9e6910c2e7d9d493c87922cf95ae3c70fff5644c7295f02e474d5fabdc2c9f42dbcc2d9d85cc25e9b6c3ba9ec8671b580093a35af1402183fa18df93a SHA512 4946b1675293920dc6e716b0a7927ce845abd833b2a33c41542b90760c6ab6832a1faede4c783133b32e616d69a8fcf2d131ca54cd504b0596fc0a92030cd1fa
diff --git a/sci-libs/volk/volk-2.5.1.ebuild b/sci-libs/volk/volk-2.5.1.ebuild
new file mode 100644
index 000000000000..dbfc78069397
--- /dev/null
+++ b/sci-libs/volk/volk-2.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ !<net-wireless/gnuradio-3.8
+ dev-libs/boost:=
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')"
+
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
+ python_optimize
+}