summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-29 14:57:18 +0000
committerMichał Górny <mgorny@gentoo.org>2024-02-03 08:22:34 +0100
commit1f6128143a5f8bb3dd26c112a1269099d7cde9c9 (patch)
tree3cb9e03338adb4e3c5a7a6b4a38cc4fb1d291b6d /sci-libs
parentdev-python/trimesh: Bump to 4.1.3 (diff)
downloadgentoo-1f6128143a5f8bb3dd26c112a1269099d7cde9c9.tar.gz
gentoo-1f6128143a5f8bb3dd26c112a1269099d7cde9c9.tar.bz2
gentoo-1f6128143a5f8bb3dd26c112a1269099d7cde9c9.zip
sci-libs/caffe2: do not move torch headers; symlink them
This allows to use provided CMake configuration to build other projects (like intel-extension-for-pytorch). Closes: https://bugs.gentoo.org/923269 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35073 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-2.1.2-r3.ebuild (renamed from sci-libs/caffe2/caffe2-2.1.2-r2.ebuild)5
1 files changed, 2 insertions, 3 deletions
diff --git a/sci-libs/caffe2/caffe2-2.1.2-r2.ebuild b/sci-libs/caffe2/caffe2-2.1.2-r3.ebuild
index f45e501e8567..9b7554309dbc 100644
--- a/sci-libs/caffe2/caffe2-2.1.2-r2.ebuild
+++ b/sci-libs/caffe2/caffe2-2.1.2-r3.ebuild
@@ -223,16 +223,15 @@ src_install() {
rm -rf python
mkdir -p python/torch/include || die
mv "${ED}"/usr/lib/python*/site-packages/caffe2 python/ || die
- mv "${ED}"/usr/include/torch python/torch/include || die
if use cuda; then
mv "${ED}${S}"/nvfuser python/nvfuser || die
mv "${ED}"/usr/$(get_libdir)/nvfuser.so python/nvfuser/_C.so || die
fi
- rm -rf "${ED}${S}"/test
- rm -rf "${ED}${S}"/third_party
cp torch/version.py python/torch/ || die
python_domodule python/caffe2
python_domodule python/torch
+ ln -s ../../../../../include/torch \
+ "${D}$(python_get_sitedir)"/torch/include/torch || die # bug 923269
if use cuda; then
python_domodule python/nvfuser
fi