summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-05-19 22:09:03 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-05-19 22:09:03 +0200
commit55c3c8cf4badea39c16ec491928d2363df72f892 (patch)
treecd590603c8985aa5dcef7ddd7f99cbdaa898c75b /sci-libs
parentsys-apps/dbus-broker: drop 30 (diff)
downloadgentoo-55c3c8cf4badea39c16ec491928d2363df72f892.tar.gz
gentoo-55c3c8cf4badea39c16ec491928d2363df72f892.tar.bz2
gentoo-55c3c8cf4badea39c16ec491928d2363df72f892.zip
sci-libs/onnx: inherit python-any-r1
Closes: https://bugs.gentoo.org/846452 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/onnx-1.11.0-r1.ebuild (renamed from sci-libs/onnx/onnx-1.11.0.ebuild)15
1 files changed, 13 insertions, 2 deletions
diff --git a/sci-libs/onnx/onnx-1.11.0.ebuild b/sci-libs/onnx/onnx-1.11.0-r1.ebuild
index 8a650bee773f..5b2ac804bf1d 100644
--- a/sci-libs/onnx/onnx-1.11.0.ebuild
+++ b/sci-libs/onnx/onnx-1.11.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-any-r1 cmake
DESCRIPTION="Open Neural Network Exchange (ONNX)"
HOMEPAGE="https://github.com/onnx/onnx"
@@ -17,7 +18,17 @@ RESTRICT="test"
DEPEND=""
RDEPEND="${DEPEND}
dev-libs/protobuf"
-BDEPEND="dev-util/patchelf"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/patchelf
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
src_install() {
cmake_src_install