summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-11-11 17:20:03 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-11-11 17:21:42 +0100
commitb38f4eb8d5464f99182d356e4941bea648ec5b3f (patch)
tree73b07416bda9f819e448d917642f144a52a34bec /sci-libs
parentapp-i18n/ibus-m17n: new upstream release (diff)
downloadgentoo-b38f4eb8d5464f99182d356e4941bea648ec5b3f.tar.gz
gentoo-b38f4eb8d5464f99182d356e4941bea648ec5b3f.tar.bz2
gentoo-b38f4eb8d5464f99182d356e4941bea648ec5b3f.zip
sci-libs/onnx: add ONNX_USE_LITE_PROTO=ON
Closes: https://bugs.gentoo.org/915843 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/onnx-1.14.0-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-libs/onnx/onnx-1.14.0-r2.ebuild b/sci-libs/onnx/onnx-1.14.0-r2.ebuild
index 7fcd28a9355b..f3f43c3fddd3 100644
--- a/sci-libs/onnx/onnx-1.14.0-r2.ebuild
+++ b/sci-libs/onnx/onnx-1.14.0-r2.ebuild
@@ -41,8 +41,9 @@ src_prepare() {
}
src_configure() {
- local mycmakeargs=(
+ mycmakeargs=(
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
)
cmake_src_configure
use python && distutils-r1_src_configure
@@ -50,7 +51,7 @@ src_configure() {
src_compile() {
cmake_src_compile
- use python && distutils-r1_src_compile
+ use python && CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
}
src_install() {