summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-02 05:43:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-02 06:46:53 +0200
commitca44bf0199087d61fc54c515f97b50775fb430f7 (patch)
treee9abec69fcc4dfafd69242d8795e7fd75da7c948 /sci-libs
parentdev-python/iminuit: Bump to 2.12.1 (diff)
downloadgentoo-ca44bf0199087d61fc54c515f97b50775fb430f7.tar.gz
gentoo-ca44bf0199087d61fc54c515f97b50775fb430f7.tar.bz2
gentoo-ca44bf0199087d61fc54c515f97b50775fb430f7.zip
sci-libs/shapely: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapely/Manifest1
-rw-r--r--sci-libs/shapely/metadata.xml4
-rw-r--r--sci-libs/shapely/shapely-1.8.2.ebuild50
3 files changed, 53 insertions, 2 deletions
diff --git a/sci-libs/shapely/Manifest b/sci-libs/shapely/Manifest
index 2848f35bb31b..0145b67b8f00 100644
--- a/sci-libs/shapely/Manifest
+++ b/sci-libs/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-1.7.1.tar.gz 293368 BLAKE2B 14d9cb0c2b486a3a20b71c0cde7260ec357287ea020352c0320eea07b91674605bdcd22512b33c5ac5a71b89c3d811946f8dd6d3b90c61398203a4c68f30d067 SHA512 72070437960a8c1cf6504b5f4ccc8ec509f87fb6a90178e291aff14889f5add89f9ed4f7e9a19799ce0835c1aea3f0241eaa6efd4d8ea5b879f2167f7c1de50a
+DIST shapely-1.8.2.gh.tar.gz 322064 BLAKE2B f21f91eb58818aa30464c719b1079d382c5a00f13eda70c532e4a12f1612284240e5c8c110a867c74eaa4aac5f3a21fd10b23c7ce781808d4adc871d038b8b2b SHA512 c85323f180622235257aed28c85640c63bb43cbcb2bd7ed9b354a0f23a92e0ca8becf7a94e85edea3a90cfd01017ddfc6f268f4bb2945639c2cae29a73292bd6
diff --git a/sci-libs/shapely/metadata.xml b/sci-libs/shapely/metadata.xml
index fb27f29d1c11..86aee655948a 100644
--- a/sci-libs/shapely/metadata.xml
+++ b/sci-libs/shapely/metadata.xml
@@ -11,9 +11,9 @@
Shapely is not concerned with data formats or coordinate systems, but can be readily integrated with packages that are.
</longdescription>
<upstream>
- <bugs-to>https://github.com/Toblerity/Shapely/issues</bugs-to>
+ <bugs-to>https://github.com/shapely/shapely/issues</bugs-to>
<doc>https://shapely.readthedocs.io</doc>
- <remote-id type="github">Toblerity/Shapely</remote-id>
+ <remote-id type="github">shapely/shapely</remote-id>
<remote-id type="pypi">Shapely</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-libs/shapely/shapely-1.8.2.ebuild b/sci-libs/shapely/shapely-1.8.2.ebuild
new file mode 100644
index 000000000000..e123057db79a
--- /dev/null
+++ b/sci-libs/shapely/shapely-1.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/Shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/matplotlib
+
+src_prepare() {
+ rm -r _vendor || die
+ sed -i -e 's:_vendor\.::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf shapely || die
+ epytest
+}